Package Search
 
Members: 353 | Topics: 767 | Posts: 3211
We welcome our newest member: ClintBarton
Info
» You aren't logged in, login or registerOnline: No members and 19 guests | Time: 21:28
Need help with cdemu
paldo Support Forum    paldo    General Support
Reply Reply   Subscribe Topic Subscribe Topic
2 posts found.
 Need help with cdemu
Moderator
 
 
Linux-Dude
 
Posts: 1187
Registered: 2006-11-23
I wrote once a wiki for cdemu and Ubuntu 6.10 German CDEmu Wiki.

Now I want to do it for paldo. Thats my XML:

Code[In neuem Fenster öffnen]
<?xml version="1.0"?>
<package name="cdemu">
<description>Mount all Images</description>
<releases>
<release version="0.8" revision="1" branch="testing">
<deps>
<dep name="linux-headers"/>
</deps>
<build>
<script>
<archive name="cdemu-$VERSION">
<cmd>make -j 2</cmd>
<cmd>make install</cmd>
</archive>
</script>
</build>
</release>
</releases>
</package>


When I try to modprobe cdemu I got this:

Code[In neuem Fenster öffnen]
sudo modprobe cdemu
FATAL: Error inserting cdemu (/lib/modules/2.6.19.2-paldo1/misc/cdemu.ko): Unknown symbol in module, or unknown parameter (see dmesg)


Did I miss something? Maybe I need the source of the kernel:

Zitat
###*###*###
### 2 ###
you need the source of your current running kernel.
/lib/modules/`uname -r`/build/include needs to point at it. if you're not
sure if it points to the righ kernel just type: ls -la /lib/modules/`uname
-r`/build if its the correct kernel source all is ok. ;-)

###*###*###
### 3 ###
$ make

and as root

###*###*###
### 4 ###
# make install

###*###*###
### 5 ###
now we can load the kernel module just with typing

# modprobe cdemu

no message should be given by this command

for you Debian users (maybe others), you might have to run `update-modules`
first

###*###*###
### 6 ###
after the install you just need to call cdemu to get the help screen of the
userspace program

If you're using devfs, then nodes will show up in /dev/cdemu/ automagically.
If you're using udev, you might want to add this to /etc/udev/rules.d/99cdemu:
KERNEL="cdemu*", NAME="cdemu/%n", SYMLINK="%n"
and the following to /etc/udev/permissions.d/99cdemu:
cdemu/*:root:root:0664
otherwise you'll get a bunch of nodes showing up in /dev/ instead of
/dev/cdemu/
If you're using just a static /dev, then each time you load cdemu the major
number may change. See /proc/devices for the current major number. You can
also load cdemu with the 'cdemu_major' parameter to control the major used.

ps: Any bug reports, comments, feature requests wished.


The problem is only:

Code[In neuem Fenster öffnen]
[amnon@virgin:~]$ sudo upkg-install --tag=source linux-2.6
Generating script...
Writing script...
Executing script...
The following packages have been skipped as no binary is available yet:
linux-2.6-2.6.18.5-paldo1

The following extra packages will be installed:
linux-2.6-source-2.6.18.5-paldo1

The following packages will be built from source:
linux-2.6-source-2.6.18.5-paldo1

Do you want to continue? [Y/n]


There is no source for kernel-testing ...

I also tried this:

Code[In neuem Fenster öffnen]
[amnon@virgin:~]$ sudo upkg-build --disable-binary linux-2.6
Generating script...
Writing script...
Executing script...
System already up-to-date.
[amnon@virgin:~]$ sudo upkg-reinstall --disable-binary linux-2.6
ERROR: Package linux-2.6 not found.
Profile   Private Message   E-Mail
Created: 2007-01-19 13:28 | Modified: 2007-01-19 13:46 by Amnon82
Highlight selected Text   Edit   Delete   Quote Reply
 Re: Need help with cdemu
Administrator
 
 
 
Posts: 426
Registered: 2004-09-09
It looks like cdemu hasn't been updated yet for 2.6.19. There is probably a patch somewhere to fix that.

The linux-2.6-source package is not needed anymore in testing and unstable, the required kernel headers are always installed now. The package will be removed with the release of paldo 1.9 in about two weeks.
Profile   Private Message   Web
Created: 2007-01-19 19:01
Highlight selected Text   Edit   Delete   Quote Reply
Subscribe Topic Subscribe Topic
powered by bitron board 1.23a