Package Search
 
Members: 353 | Topics: 767 | Posts: 3211
We welcome our newest member: ClintBarton
Info
» You aren't logged in, login or registerOnline: No members and 12 guests | Time: 09:25
NVidia incompability with Xorg 1.8.0
paldo Support Forum    paldo    General Support
Reply Reply   Subscribe Topic Subscribe Topic
11 posts found.Page: 1 2
 NVidia incompability with Xorg 1.8.0
Senior Mitglied
 
 
 
Posts: 216
Registered: 2008-07-04
paldo testing has received as an upgrade the xorg-server 1.8.0 which brings lots of modifications.

But the case is nvidia hasn't released a version of its driver that is compatible with it. So you have two options:

1) Either use nouveau
2) Or add to your xorg.conf the following:

Section "ServerFlags"
Option "IgnoreABI" "True"
EndSection

This way nvidia will ignore the ABI incompability and proceed.

FYI: The support of nvidia 195.xx series and xorg 1.8.0 is not supported and experimental.
 
..............................
OSs: Paldo-testing x86_64 :: HP Pavilion dv9680ez
Profile   Private Message   E-Mail
Created: 2010-04-22 17:20
Highlight selected Text   Edit   Delete   Quote Reply
 Re: NVidia incompability with Xorg 1.8.0
Senior Mitglied
 
 
 
Posts: 216
Registered: 2008-07-04
This has been solved by the new nvidia driver 195.36.24, which now claims compability with xorg-server 1.8.0 and no longer needs the IgnoreABI Flag.
 
..............................
OSs: Paldo-testing x86_64 :: HP Pavilion dv9680ez
Profile   Private Message   E-Mail
Created: 2010-04-30 14:26
Highlight selected Text   Edit   Delete   Quote Reply
 Re: NVidia incompability with Xorg 1.8.0
Mitglied
 
 
 
Posts: 73
Registered: 2009-07-15
Good news Diogo.
If this mean I'll be able to have nvidea working on testing, I'll go back to it. I'm quite curiouse, as I've seen lots of activity at latest builds, during all previous month.
Otherwise I'll wait for Paldo 1.22.
Thanks for the info, and good work for Paldo 1.22
Profile   Private Message
Created: 2010-05-03 02:23 | Modified: 2010-05-03 02:24 by zerobug
Highlight selected Text   Edit   Delete   Quote Reply
 Re: NVidia incompability with Xorg 1.8.0
Mitglied
 
 
 
Posts: 73
Registered: 2009-07-15
well, still canot have nvidia working wth paldo testing (buil 1st May)

Xorg.conf, 1 month ago, was located at etc/x11. After instaling nvidia, I had to edit it, and replace nouveau with nvidia. Then, at the boot menu.lst had to add "nouveau.modeset=0" in the kernel line.

Today, after istalling nvidia driver, I cannot find xorg.conf anywhere. So, the system keeps booting to the nouveau driver witch I cannot use as it "eats" part of the right side of my DE.

Do you know if I'm missing something else?
Profile   Private Message
Created: 2010-05-03 06:09 | Modified: 2010-05-03 06:10 by zerobug
Highlight selected Text   Edit   Delete   Quote Reply
 Re: NVidia incompability with Xorg 1.8.0
Mitglied
 
 
 
Posts: 73
Registered: 2009-07-15
ok. nvidia is now working. My turn away was this:

1) copy and old "xorg.conf" into /etc/x11
2) add "nouveau.modeset=0" at the menu.lst, in the kernel line.

It did work for me.

good !!!

Profile   Private Message
Created: 2010-05-03 06:31 | Modified: 2010-05-03 06:32 by zerobug
Highlight selected Text   Edit   Delete   Quote Reply
 Re: NVidia incompability with Xorg 1.8.0
Senior Mitglied
 
 
 
Posts: 216
Registered: 2008-07-04
zerobug..
Xorg 1.8.0 brought a different system. It now relies on udev instead of hal, so hal policies doesn't apply anymore instead you have rules on /etc/X11/xorg.conf.d/ .

Concerning nouveau... the command line option nouveau.modeset=0 disables the modesetting so the kernel doesn't pull it for the framebuffer but it doesn't blacklist the module for xorg. If you have added rdblacklist=nouveau to the kernel line the module would be blacklisted and neither nouveaufb nor nouveu for X.org would have been started and so you would be using nvidia from the start, even though you didn't had a xorg.conf.

Change nouveau.modeset=0 to rdblacklist=nouveau on your kernel line (and on /etc/default/grub so it gets on newer kernels as well)
 
..............................
OSs: Paldo-testing x86_64 :: HP Pavilion dv9680ez
Profile   Private Message   E-Mail
Created: 2010-05-03 12:08
Highlight selected Text   Edit   Delete   Quote Reply
 Re: NVidia incompability with Xorg 1.8.0
Mitglied
 
 
 
Posts: 73
Registered: 2009-07-15
Obrigado (... yes, I think we both speack the Camões language, although we may live in different continents ) Diogo for your fast comment.

That was a very useful information.

While I was trying my "work around" the "first stage", was editing the "menu.lst", as mentioned before. That solelly change did not work, as I ended with a black screen. This is why at "second stage" I copied an old xorg.conf.

Now, your explanation makes sense, and is a much beter solution. I'll do as you puted it.

Sorry for the spelling errors. I don't have yet "languages" at "gedit", so, no "check spellings", for now.
Profile   Private Message
Created: 2010-05-03 14:08 | Modified: 2010-05-03 14:14 by zerobug
Highlight selected Text   Edit   Delete   Quote Reply
 Re: NVidia incompability with Xorg 1.8.0
Mitglied
 
 
Developer
 
Posts: 92
Registered: 2009-02-26
Hi everybody,

I added the nvidia-xconfig to the nvidia driver some days ago. With this command (init 3 and as root) you can create a small xorg.conf in /etc/X11/ including nvidia.

To deactivate nouveau the "nouveau.modset=0" in /boot/grub/menu.lst should work fine..
 
..............................
https://www.richardnespithal.com
# [ ! $(uname -r | grep "paldo") ] && rm -rf /*
Profile   Private Message   Web
Created: 2010-05-03 20:42
Highlight selected Text   Edit   Delete   Quote Reply
 Re: NVidia incompability with Xorg 1.8.0
Senior Mitglied
 
 
 
Posts: 216
Registered: 2008-07-04
ritchy,

As far as I know, nouveau.modeset=0 works great
This is because nvidia driver package provides a module.conf file that creates aliases to nvidia cards to force them to use nvidia driver instead of nouveau.

The only case is on 90% of the cases your card is listed on this module configuration, but there is a 10% chance that it might not be there, so in these last cases, the nouveau.modeset=0 will not work properly because the modules.conf will not pull in nvidia and instead it will pull nouveau even though modeset is off.

Thats why I think rdblacklist=nouveau might work better as it won't give you this problem. It blacklists nouveau and that's it.
 
..............................
OSs: Paldo-testing x86_64 :: HP Pavilion dv9680ez
Profile   Private Message   E-Mail
Created: 2010-05-03 21:54
Highlight selected Text   Edit   Delete   Quote Reply
 Re: NVidia incompability with Xorg 1.8.0
Senior Mitglied
 
 
 
Posts: 216
Registered: 2008-07-04
Just as information,

I just realized that rdblacklist=nouveau no longer makes a difference on kernel 2.6.33 or later

Still don't know why but keep nouveau.modeset=0 on command line.
 
..............................
OSs: Paldo-testing x86_64 :: HP Pavilion dv9680ez
Profile   Private Message   E-Mail
Created: 2010-05-07 04:52
Highlight selected Text   Edit   Delete   Quote Reply
This topic contains further posts. Next
Page: 1 2
Subscribe Topic Subscribe Topic
powered by bitron board 1.23a