Package Search
 
Members: 353 | Topics: 767 | Posts: 3211
We welcome our newest member: ClintBarton
Info
» You aren't logged in, login or registerOnline: No members and 12 guests | Time: 23:28
Policy-Kit problems
paldo Support Forum    paldo    General Support
Reply Reply   Subscribe Topic Subscribe Topic
4 posts found.
 Policy-Kit problems
Junior Mitglied
 
 
 
Posts: 24
Registered: 2008-11-03
Nochmal Mahlzeit!

i read in this forum about the Policy-Kit defaults and so on.

Some problems i encouter with policy-kit is that

sometimes after an upgrade i had to reinstall polkit-1 package to get my pc working correctly.

That happened on a stable and a testing release

First time it occured about Novembre last year.

Did someone have the same problems?
 
..............................
When you need all the stunning features of MacOSX and Windows
Buy yourself a copy and live in peace!!
Profile   Private Message
Created: 2010-02-23 13:57
Highlight selected Text   Edit   Delete   Quote Reply
 Re: Policy-Kit problems
Mitglied
 
 
 
Posts: 73
Registered: 2009-07-15
I'm using Paldo since almost one year but only had the same problem just a couple of days ago, when I upgraded after a fresh install of the x86-64 testing.

I was not aware of anything in the forums about policy-kit and though it was some temp issue due to be a testing version, although I've been using Paldo testing for many months without problems.

I waited until a new iso become available to download, reinstalled these one and then updated without any problems.

Let's hope that someone who reads this can and will fix it. In the meanwhile if it happen again to me, I'll do the same way you did, instead of reinstall everything. It was nice you have mentioned it.
Profile   Private Message
Created: 2010-02-23 17:18
Highlight selected Text   Edit   Delete   Quote Reply
 Re: Policy-Kit problems
Senior Mitglied
 
 
 
Posts: 216
Registered: 2008-07-04
Hi zerobug and yuwnarg,

I did once realized that everything people were trying to do and needed the policykit authorization, the GUI for requesting the password didn't appear, then I tried to investigate and thought maybe it could have something to do with the default policies.

But I was wrong the problem was on the compilation of some programs that were preventing PolicyKit to fully function.

This happened some months ago... I reported the issue and the solution on this forum on another thread.

But know after the latest release, the linux world is actually experiencing a change on authorization requests. We have polkit-1 and policykit, both of them even though for the end user do the same, they do it differently, and PolicyKit is deprecated and beeing substituted by polkit-1.

If I'm not mistaken, NetworkManager changed from PolicyKit to Polkit-1 on version 0.8 that was just added to the testing. Please check if it really is a problem on PolicyKit or just a quirk because of PolicyKit deprecation. Another thing people might notice is KDE 4.4.0, which now relies on Polkit-1 instead of PolicyKit.

This is all about the deprecation of Hal for DeviceKit/udev, PolicyKit relies on hal, if hal stops to be used, then PolicyKit will not be functional
 
..............................
OSs: Paldo-testing x86_64 :: HP Pavilion dv9680ez
Profile   Private Message   E-Mail
Created: 2010-02-24 13:44
Highlight selected Text   Edit   Delete   Quote Reply
 Re: Policy-Kit problems
Junior Mitglied
 
 
 
Posts: 24
Registered: 2008-11-03
Hmm,

to precise my problems i had to solve with reinstalling polkit-1.

First i couldn't shutdown my pc through the gui. it took about 2-3 minutes till
the window appears where to choose reboot shutdown and so on. Choosing
shutdown it lead to the login window!! Shutdown on cli with shutdown -h worked.

The idea to reinstall everything that has to do woth PolicyKit was a window that told me
something about an error in freedesktop.org-blablabla. can't remember the whole.

So maybe it also has to do with the changes that go through Policykit, don't know.

But with the network i never experienced problems, but the bug with the passphrase, see forum!

But, thanks for posting!

 
..............................
When you need all the stunning features of MacOSX and Windows
Buy yourself a copy and live in peace!!
Profile   Private Message
Created: 2010-02-24 14:17
Highlight selected Text   Edit   Delete   Quote Reply
Subscribe Topic Subscribe Topic
powered by bitron board 1.23a