Package Search
 
Members: 353 | Topics: 767 | Posts: 3211
We welcome our newest member: ClintBarton
Info
» You aren't logged in, login or registerOnline: No members and 7 guests | Time: 22:25
Problems with paldo unstable
paldo Support Forum    paldo    General Support
Reply Reply   Subscribe Topic Subscribe Topic
8 posts found.
 Problems with paldo unstable
Mitglied
 
 
 
Posts: 70
Registered: 2008-08-24
I make a list so I don't have to write a dozen posts...

1) The notification area applet doesn't work correctly. It doesn't show the icons correctly or it doesn't show them at all!

2) PulseAudio doesn't work correctly. When I reboot my computer the volume is lowered or mute. It happens also sometimes during the normal use of the system. I tried to use alsactl to store the volume levels but nothing helped.

EDIT:
In most distributions PulseAudio is disabled by default. Even now there's a dispute between developers which indicates that the introduction of PA in GNOME has followed an "unusual" path. I suggest to disable it for now since PA is not really stable and it gives alot of problems (aka "who cares about sound balancing when I have to reset volume levels every reboot and for every application?").

3) After I finished playing some audio or video files (with audio) my speakers make a low pitched noise as a door get slammed (BAAAM). It seems like an alsa problem

4) On boot the services' scripts show the status label "done" in some strange idiom (it seems like russian). This happens also on stable and testing.
EDIT:
5) gnome-settings-daemon package need to be recompiled for broken dependency:
Code[In neuem Fenster öffnen]
** (gnome-settings-daemon:2223): WARNING **: libgnomekbd.so.3: cannot open shared object file: No such file or directory

(the library is libgnomekbd.so.4)

EDIT:
6) I found this warning inside my ~/.xsession-errors:
Code[In neuem Fenster öffnen]
** (gnome-settings-daemon:2223): WARNING **: Could not execute xrdb -nocpp -merge: Failed to execute child process "xrdb" (No such file or directory)


Any clue?
 
..............................
Running GNU/Linux Paldo 1.18 (unstable). Rock my box!
Profile   Private Message   Web
Created: 2009-07-27 20:19 | Modified: 2009-07-28 11:27 by axelgenus
Highlight selected Text   Edit   Delete   Quote Reply
 Re: Problems with paldo unstable
Senior Mitglied
 
 
 
Posts: 216
Registered: 2008-07-04
Hi axelgenus,

* I have to disagree with pulseaudio, Fedora has it enabled, mandriva too, and so does opensuse, and I think ubuntu does it either, not to mention foresight.

* Pulseaudio is working pretty good on my paldo testing with my SND-HDA-Intel model Quanta-il1, on my HP Pavillion DV9540 series.

* Your problems with it might be happening not because of PA but it might be because on paldo unstable your using gnome 2.27.x which is a development version and so not suitable yet for work (on gnome development its 2.20 2.22 2.24 2.26 2.28 the stable versions and 2.21 2.23 2.25 2.27 2.29 the development ones)

* About the strange done of the boot services I agree it happens here and it happens particularly when the service that set the keyboard layout runs

* About the BAAAM of the sounds, I had it too with mandriva 2009.1, it happened with my HDA Intel the fixing I don't know yet but my options on modprobe.conf that works are:

Code[In neuem Fenster öffnen]
 options snd-hda-intel model=quanta-il1 index=0 power_save=0 position_fix=1 


PS.: check if these problems happens on testing and stable, if not I see that half your problems are related to gnome issues which might be related to the development version I said.

 
..............................
OSs: Paldo-testing x86_64 :: HP Pavilion dv9680ez
Profile   Private Message   E-Mail
Created: 2009-07-28 12:04
Highlight selected Text   Edit   Delete   Quote Reply
 Re: Problems with paldo unstable
Mitglied
 
 
 
Posts: 70
Registered: 2008-08-24
Thank you diogo for the fix: I'll try it as soon as I come back home. I'll let you know... I thought it could be a power-saving options too and I was gonna trying to play with PA options in /etc/pulse/default.pa. I didn't know that the aggressive powersaving option for Intel HDA driver was enabled by default in the paldo kernel (I've always kept it disabled on Gentoo).

About PulseAudio: you're right, major distributions use it but keep in mind that it's been developed on Fedora and RedHat has a strong position among GNOME's developers; other distributions adopted it but as I can see googling around it gives problems everywhere. Other distros, such as ArchLinux (and I think Ubuntu too), don't enable PulseAudio by default. Let's face it: PA is anything but stable and its adoption in GNOME is very premature.
 
..............................
Running GNU/Linux Paldo 1.18 (unstable). Rock my box!
Profile   Private Message   Web
Created: 2009-07-28 12:13 | Modified: 2009-07-28 12:15 by axelgenus
Highlight selected Text   Edit   Delete   Quote Reply
 Re: Problems with paldo unstable
Mitglied
 
 
 
Posts: 70
Registered: 2008-08-24
That's it! Finally my sound card doesn't slam a door over my face anymore!!!

Now I'm going to play around PA to see if it's a version problem (improbable, testing and unstable uses the same PA version) or a GNOME problem (I'll try testing and stable).

EDIT:
I also found a solution for the weather icon not appearing in the clock applet: I had to set up a default location! The applet doesn't set it up automatically when the user select the first location (bug?).

BTW, I've enabled the debug log-level for pulseaudio and here it goes:

Code[In neuem Fenster öffnen]
D: main.c: Started as real root: no, suid root: yes
I: main.c: PolicyKit refuses acquire-high-priority privilege.
I: main.c: Called SUID root and real-time and/or high-priority scheduling was requested in the configuration. However, we lack the necessary privileges:
I: main.c: We are not in group 'pulse-rt', PolicyKit refuse to grant us the requested privileges and we have no increase RLIMIT_NICE/RLIMIT_RTPRIO resource limits.
I: main.c: For enabling real-time/high-priority scheduling please acquire the appropriate PolicyKit privileges, or become a member of 'pulse-rt', or increase the RLIMIT_NICE/RLIMIT_RTPRIO resource limits for this user.
I: main.c: setrlimit(RLIMIT_NICE, (31, 31)) failed: Operation not permitted
I: main.c: setrlimit(RLIMIT_RTPRIO, (9, 9)) failed: Operation not permitted
D: main.c: Can realtime: no, can high-priority: no
D: main.c: Can realtime: no, can high-priority: no
I: main.c: Daemon startup successful.


In my system there isn't a pulse-rt group.

EDIT2:
Even though I still get those warning messages and I can't get no realtime or high-priority PA server finally I've been able to make PA work correctly. I really don't know why: I simply deleted the ~/.pulse folder and the ~/.pulse-cookie file. FINALLY IT WORKS!
 
..............................
Running GNU/Linux Paldo 1.18 (unstable). Rock my box!
Profile   Private Message   Web
Created: 2009-07-28 15:21 | Modified: 2009-07-28 18:46 by axelgenus
Highlight selected Text   Edit   Delete   Quote Reply
 Re: Problems with paldo unstable
Senior Mitglied
 
 
 
Posts: 216
Registered: 2008-07-04
It seems paldo has passed through some upgrades on hal and devicekit and I know it can cause some problems, so it probably made some change that required different options, about realtime and highpriority, check the authorizations of policykit and grant it for your user:

Code[In neuem Fenster öffnen]
$ sudo polkit-auth --user $YOUR_USER --grant org.pulseaudio.acquire-real-time
$ sudo polkit-auth --user $YOUR_USER --grant org.pulseaudio.acquire-high-priority


It seems paldo comes with no policykit granting for the default user which means that you can't even set a connection configuration from networkmanager as a system connection avalaible to all users.
 
..............................
OSs: Paldo-testing x86_64 :: HP Pavilion dv9680ez
Profile   Private Message   E-Mail
Created: 2009-07-29 00:06
Highlight selected Text   Edit   Delete   Quote Reply
 Re: Problems with paldo unstable
Mitglied
 
 
 
Posts: 70
Registered: 2008-08-24
Thank you for the tip: I'll try it as soon as possible.

Yesterday the lag between a fullHD video and the DTS track was something around 2 seconds (not a CPU issue, I own a Intel Quad Core Q8400).

EDIT:
Okay I only gave my user the right to use the high-priority PA server. Now in ~/.xsession-errors I found:
Code[In neuem Fenster öffnen]
D: main.c: Started as real root: no, suid root: yes
I: main.c: PolicyKit grants us acquire-high-priority privilege.
I: main.c: setrlimit(RLIMIT_NICE, (31, 31)) failed: Operation not permitted
I: main.c: setrlimit(RLIMIT_RTPRIO, (9, 9)) failed: Operation not permitted
I: core-util.c: Successfully gained nice level -11.
D: main.c: Can realtime: yes, can high-priority: yes
I: main.c: Giving up CAP_NICE
D: main.c: Can realtime: no, can high-priority: no
I: main.c: Daemon startup successful.


I don't understand if it now runs in high-priority or not (I don't want a realtime server because I use unstable and a bug could lock my computer).
 
..............................
Running GNU/Linux Paldo 1.18 (unstable). Rock my box!
Profile   Private Message   Web
Created: 2009-07-29 09:33 | Modified: 2009-07-29 18:42 by axelgenus
Highlight selected Text   Edit   Delete   Quote Reply
 Re: Problems with paldo unstable
Senior Mitglied
 
 
 
Posts: 216
Registered: 2008-07-04
the weird thing is that I have HDA Intel as well, and I upgraded to unstable and had no problems at all so far, no errors no nothing
Couldn't it be because you were having problems on sound (because of modprobe options for snd-hda-intel) that you might change some configurations for pulseaudio that may be causing these problems. You can try going back to the defaults to see if the problems remain and the reconfigure acoording to your needs
 
..............................
OSs: Paldo-testing x86_64 :: HP Pavilion dv9680ez
Profile   Private Message   E-Mail
Created: 2009-07-29 23:05 | Modified: 2009-07-29 23:07 by diogo
Highlight selected Text   Edit   Delete   Quote Reply
 Re: Problems with paldo unstable
Mitglied
 
 
 
Posts: 70
Registered: 2008-08-24
I have the original paldo configuration: when I modify something I always make a backup copy so I can fall back eventually.
 
..............................
Running GNU/Linux Paldo 1.18 (unstable). Rock my box!
Profile   Private Message   Web
Created: 2009-07-30 09:15 | Modified: 2009-07-30 09:16 by axelgenus
Highlight selected Text   Edit   Delete   Quote Reply
Subscribe Topic Subscribe Topic
powered by bitron board 1.23a