Package Search
 
Members: 353 | Topics: 767 | Posts: 3211
We welcome our newest member: ClintBarton
Info
» You aren't logged in, login or registerOnline: No members and 14 guests | Time: 00:41
Enable wireless connection
paldo Support Forum    paldo    General Discussion
Reply Reply   Subscribe Topic Subscribe Topic
6 posts found.
 Enable wireless connection
Junior Mitglied
 
 
 
Posts: 26
Registered: 2008-06-15
Ok, now this is my very last issue with my laptop - whatever guides i follow I can't get my network manager to use wireless - it says its disabled, while all sorts of iw modules are loaded. Any useful advise on this topic? thanks in advance.
Profile   Private Message   E-Mail
Created: 2009-07-27 00:15 | Modified: 2009-07-27 01:02 by dichev
Highlight selected Text   Edit   Delete   Quote Reply
 Re: Enable wireless connection
Mitglied
 
 
 
Posts: 70
Registered: 2008-08-24
HP Pavilion dv3000 has a wireless switch above the keyboard. Try to push it once and see if the radio works. Otherwise please post your "dmesg".
 
..............................
Running GNU/Linux Paldo 1.18 (unstable). Rock my box!
Profile   Private Message   Web
Created: 2009-07-27 08:33
Highlight selected Text   Edit   Delete   Quote Reply
 Re: Enable wireless connection
Junior Mitglied
 
 
 
Posts: 26
Registered: 2008-06-15
hm, 1st, I always thought that switch is for the bluetooth, but however it made no difference. Problem got solved, anyway. After giving ndiswrapper everything I got, i removed it and probed the old module just to return things to the state in which i picked them... and wireless worked. No explanation.
Profile   Private Message   E-Mail
Created: 2009-07-27 14:08
Highlight selected Text   Edit   Delete   Quote Reply
 Re: Enable wireless connection
Mitglied
 
 
 
Posts: 70
Registered: 2008-08-24
That switch disable both the bluetooth and the wireless antennas. However I guess your problem was about either ndiswapper and iwl module trying to get both access to the device deadlocking each other. Usually Intel devices have really good linux native drivers/modules because Intel develops them directly so I highly suggest you to use *only* the iwl module (I've never got problem with it).
 
..............................
Running GNU/Linux Paldo 1.18 (unstable). Rock my box!
Profile   Private Message   Web
Created: 2009-07-27 15:56 | Modified: 2009-07-27 15:58 by axelgenus
Highlight selected Text   Edit   Delete   Quote Reply
 Re: Enable wireless connection
Junior Mitglied
 
 
 
Posts: 26
Registered: 2008-06-15
I found out what was causing the problem: the switch on the laptop MUST be on when the module is loaded. And, as during startup the switch is off, the wireless doesn't work even if I push the switch later, so I added an app to my panel with this command in it:
Code[In neuem Fenster öffnen]
gksu "sh -c 'rmmod iwlagn; modprobe iwlagn'"

to reaload the module after I push the wireless button. I dunno how to make it execute on switch press so that I don't have to click it each time, though.
Profile   Private Message   E-Mail
Created: 2009-07-27 17:27
Highlight selected Text   Edit   Delete   Quote Reply
 Re: Enable wireless connection
Senior Mitglied
 
 
 
Posts: 216
Registered: 2008-07-04
You might probably get it configured through hal, and I guess the configuration should be set on /etc/hal/fdi/policy/70-rfkill-switch.fdi basing on the default from hal at /usr/share/hal/fdi/policy/10osvendor/10-rfkill-switch.fdi

Copy /usr/share/hal/fdi/policy/10osvendor/10-rfkill-switch.fdi to /etc/hal/fdi/policy/70-rfkill-switch.fdi and then try editing the file but I don't know yet how, haven't learn a lot about hal fdi files yet but that file sets the commands when the trigger of wireless cards happens.
 
..............................
OSs: Paldo-testing x86_64 :: HP Pavilion dv9680ez
Profile   Private Message   E-Mail
Created: 2009-07-29 00:11
Highlight selected Text   Edit   Delete   Quote Reply
Subscribe Topic Subscribe Topic
powered by bitron board 1.23a