Package Search
 
Members: 353 | Topics: 767 | Posts: 3211
We welcome our newest member: ClintBarton
Info
» You aren't logged in, login or registerOnline: No members and 14 guests | Time: 19:01
Can't install wine
paldo Support Forum    paldo    General Support
Reply Reply   Subscribe Topic Subscribe Topic
7 posts found.
 Can't install wine
Mitglied
 
 
 
Posts: 70
Registered: 2008-08-24
Hi guys,

I'm trying to install wine on Paldo unstable but upkg just tells me "the system is already up-to-date".

PS: I checked if it's already installed but it's not...
 
..............................
Running GNU/Linux Paldo 1.18 (unstable). Rock my box!
Profile   Private Message   Web
Created: 2009-07-22 12:52 | Modified: 2009-07-22 12:55 by axelgenus
Highlight selected Text   Edit   Delete   Quote Reply
 Re: Can't install wine
Administrator
 
 
 
Posts: 426
Registered: 2004-09-09
Are you on x86_64? Wine requires a 32-bit environment for Win32 applications.
Profile   Private Message   Web
Created: 2009-07-22 13:02
Highlight selected Text   Edit   Delete   Quote Reply
 Re: Can't install wine
Mitglied
 
 
 
Posts: 70
Registered: 2008-08-24
I know but recent releases can be build on 64-bit systems. It just needs GCC 4.4. It's experimental but should fit in the unstable repository.

More info @ http://wiki.winehq.org/Wine64
 
..............................
Running GNU/Linux Paldo 1.18 (unstable). Rock my box!
Profile   Private Message   Web
Created: 2009-07-22 13:53 | Modified: 2009-07-22 13:54 by axelgenus
Highlight selected Text   Edit   Delete   Quote Reply
 Re: Can't install wine
Administrator
 
 
 
Posts: 426
Registered: 2004-09-09
You will only be able to run Win64 applications, though. I doubt this would be very useful as they are still quite rare.
Profile   Private Message   Web
Created: 2009-07-22 13:57
Highlight selected Text   Edit   Delete   Quote Reply
 Re: Can't install wine
Mitglied
 
 
 
Posts: 70
Registered: 2008-08-24
The Wine wiki is somewhat chaotic about this: 32-bit apps should work also on Wine64 since the last part of the wikipage contains a list of "Apps whose 32-bit versions work well with Wine".
 
..............................
Running GNU/Linux Paldo 1.18 (unstable). Rock my box!
Profile   Private Message   Web
Created: 2009-07-22 14:06 | Modified: 2009-07-22 14:07 by axelgenus
Highlight selected Text   Edit   Delete   Quote Reply
 Re: Can't install wine
Administrator
 
 
 
Posts: 426
Registered: 2004-09-09
The page might be a bit confusing, but it only lists Win64 applications. The 32-bit comment is just for the categorization of the 64-bit applications.

Wine does not support running 32-bit applications in a 64-bit only environment as it depends on various external libraries. Many 64-bit distros provide 32-bit compatibility libraries for this purpose, however, paldo x86_64 does not, it's a pure 64-bit system.
Profile   Private Message   Web
Created: 2009-07-22 14:18
Highlight selected Text   Edit   Delete   Quote Reply
 Re: Can't install wine
Mitglied
 
 
 
Posts: 70
Registered: 2008-08-24
Uhm... so the only way to run Windows binaries on a x86_64 Paldo system is to use virtualization right?
 
..............................
Running GNU/Linux Paldo 1.18 (unstable). Rock my box!
Profile   Private Message   Web
Created: 2009-07-22 19:05
Highlight selected Text   Edit   Delete   Quote Reply
Subscribe Topic Subscribe Topic
powered by bitron board 1.23a