Package Search
 
Members: 353 | Topics: 767 | Posts: 3211
We welcome our newest member: ClintBarton
Info
» You aren't logged in, login or registerOnline: No members and 9 guests | Time: 00:39
[FIXED] ALT GR Problem, it stops working
paldo Support Forum    paldo    General Support
Reply Reply   Subscribe Topic Subscribe Topic
12 posts found.Page: 1 2
 [FIXED] ALT GR Problem, it stops working
Senior Mitglied
 
 
 
Posts: 216
Registered: 2008-07-04
Hi everyone, I need help

I've been using now my paldo system 64 bit for like one year on diferent machines, recently I got a hp pavilion dv 9500 series and it has a swiss german keyboard.

I found out that after a while the AltGR key stops working on Xorg, but it keeps working on consoles.

Without AltGR on this layout I have no ~ ' @ # { } [ ] \ symbols that everyone need, mainly the @ for emails.

So if I come again and use the keyboard gnome configuration tool and select any other layout and then come back to evdev switzerland keyboard configuration, I get Alt GR working again for a while so this might be a problem of configuration of evdev.

here is the configuration of my /etc/default/kbd :
Code[In neuem Fenster öffnen]

# Default keymap
DEFKEYMAP=sg-latin1
XKBLAYOUT=ch
XKBVARIANT=de


Highlighting that the sg-latin1 is fine on the consoles, the problem remains on ch_de keyboard and evdev configuration.

So does anyone has swiss german keyboard and know what is the problem for me?

Oh, forgot to say, Alt GR stops to work randomly, there isn't a constant reason for it to stop, to prove it I did a test, just turn on the laptop and didn't touch it at all, 8 hours later when I came back the Alt GR wasn't working, rebooted and it was working!!!
 
..............................
OSs: Paldo-testing x86_64 :: HP Pavilion dv9680ez
Profile   Private Message   E-Mail
Created: 2009-06-02 03:07 | Modified: 2009-10-26 11:17 by diogo
Highlight selected Text   Edit   Delete   Quote Reply
 Re: [NOT FIXED] ALT GR Problem, it stops working
Senior Mitglied
 
 
 
Posts: 216
Registered: 2008-07-04
OK, I fixed it, I found out that it randomly changed the lv3 key so I fixed it on the configuration adding one line to /etc/default/kbd:

Code[In neuem Fenster öffnen]
# Default keymap 
DEFKEYMAP=sg-latin1
XKBLAYOUT=ch
XKBVARIANT=de
XKBOPTIONS=lv3:ralt_switch


Also on keyboard gnome configuration (since it overwrite the evdev configuration) I have to add the options on the extra parameters for the layout going on disposition options and selecting the option Key to choose Third Level/Right Alt .

After that the cpu was rebooted and now its been on for 8 hours and the altgr still works
 
..............................
OSs: Paldo-testing x86_64 :: HP Pavilion dv9680ez
Profile   Private Message   E-Mail
Created: 2009-06-02 12:16 | Modified: 2009-06-07 14:25 by diogo
Highlight selected Text   Edit   Delete   Quote Reply
 Re: [NOT FIXED] ALT GR Problem, it stops working
Senior Mitglied
 
 
 
Posts: 216
Registered: 2008-07-04
So I thought It was fixed, but it is not and it seems to have something to do with epiphany web browser and gnome 2.26

I just installed firefox, and I'll try paldo with XFCE to see if the problem go away if so, it proves that this is a problem with epiphany and gnome on paldo turning it into a major bug for who has a swiss german keyboard.
 
..............................
OSs: Paldo-testing x86_64 :: HP Pavilion dv9680ez
Profile   Private Message   E-Mail
Created: 2009-06-07 14:24
Highlight selected Text   Edit   Delete   Quote Reply
 Re: [NOT FIXED] ALT GR Problem, it stops working
Administrator
 
 
 
Posts: 426
Registered: 2004-09-09
I've always used the Swiss German keyboard layout and I've never had issues with Alt Gr. It's even the default in paldo if you install with the locale "English (Switzerland)" or "German (Switzerland)". I haven't specified any XKBOPTIONS.
Profile   Private Message   Web
Created: 2009-06-07 14:41
Highlight selected Text   Edit   Delete   Quote Reply
 Re: [NOT FIXED] ALT GR Problem, it stops working
Senior Mitglied
 
 
 
Posts: 216
Registered: 2008-07-04
Well, for example, I'm using now and it is working, but 10 minutes ago I was using epiphany browser to surf the web and it stopped working, to make it work again I rebooted and know I'm not using epiphany to surf the web anymore

I searched the google and found this happens on other linux distributions as well but no one can really tell why and how it happens.

The truth is that it happens on distributions that use evdev, the one that dont use it (using xorg 7.3) dont have this problem.
 
..............................
OSs: Paldo-testing x86_64 :: HP Pavilion dv9680ez
Profile   Private Message   E-Mail
Created: 2009-06-07 14:49
Highlight selected Text   Edit   Delete   Quote Reply
 Re: [NOT FIXED] ALT GR Problem, it stops working
Senior Mitglied
 
 
 
Posts: 216
Registered: 2008-07-04
Also my locale is Italian (it_IT.UTF-8), does the english and german set for the switzerland locale are as well UTF-8, maybe I should set my locale to ISO?
 
..............................
OSs: Paldo-testing x86_64 :: HP Pavilion dv9680ez
Profile   Private Message   E-Mail
Created: 2009-06-07 15:12
Highlight selected Text   Edit   Delete   Quote Reply
 Re: [NOT FIXED] ALT GR Problem, it stops working
Senior Mitglied
 
 
 
Posts: 216
Registered: 2008-07-04
Now I can tell you this is a problem with epiphany and gnome

I'm using paldo testing, with gnome 2.26.2 with epiphany 2.26.2 (as in paldo's repo)

If you stop using epiphany browser, the problem goes away. (no need to change anything on /etc/default/kbd , it is not a configuration problem it is a bug on epiphany with evdev as far as I see.
 
..............................
OSs: Paldo-testing x86_64 :: HP Pavilion dv9680ez
Profile   Private Message   E-Mail
Created: 2009-06-07 17:49
Highlight selected Text   Edit   Delete   Quote Reply
 Re: [NOT FIXED] ALT GR Problem, it stops working
Senior Mitglied
 
 
 
Posts: 216
Registered: 2008-07-04
OK, this is very problematic for me, it is not exactly paldo and epiphany, on fedora 11 with gnome 2.26 it happens as well.

This is starting to be really frustating.

I'll try to use other DM for a while to see if it happens.
 
..............................
OSs: Paldo-testing x86_64 :: HP Pavilion dv9680ez
Profile   Private Message   E-Mail
Created: 2009-06-10 13:13
Highlight selected Text   Edit   Delete   Quote Reply
 Re: [NOT FIXED] ALT GR Problem, it stops working
Senior Mitglied
 
 
 
Posts: 16777215
Registered: 2008-12-03
I also use the swiss german keyboard. Never had a problem with it, but I don't use epiphany but firefox and 32 bit stable Paldo (with xfce).

Profile   Private Message
Created: 2009-07-17 10:09
Highlight selected Text   Edit   Delete   Quote Reply
 Re: [NOT FIXED] ALT GR Problem, it stops working
Mitglied
 
 
 
Posts: 70
Registered: 2008-08-24
I use the italian standard keymap... AltGr works out-of-box. I use Epiphany (always did) and I have no problems at all.

Are you sure the key does work? Try with another keyboard.
 
..............................
Running GNU/Linux Paldo 1.18 (unstable). Rock my box!
Profile   Private Message   Web
Created: 2009-07-17 17:07 | Modified: 2009-07-17 17:08 by axelgenus
Highlight selected Text   Edit   Delete   Quote Reply
This topic contains further posts. Next
Page: 1 2
Subscribe Topic Subscribe Topic
powered by bitron board 1.23a