Package Search
 
Members: 353 | Topics: 767 | Posts: 3211
We welcome our newest member: ClintBarton
Info
» You aren't logged in, login or registerOnline: No members and 14 guests | Time: 00:48
group scanner missing
paldo Support Forum    paldo    General Support
Reply Reply   Subscribe Topic Subscribe Topic
7 posts found.
 group scanner missing
Senior Mitglied
 
 
 
Posts: 16777215
Registered: 2008-12-03
xsane works fine as root, but I don't want to scan as root; i can't add my user-name to the group scanner, because the group scanner does not exist.
Profile   Private Message
Created: 2009-04-24 18:38
Highlight selected Text   Edit   Delete   Quote Reply
 Re: group scanner missing
Mitglied
 
 
Developer
 
Posts: 92
Registered: 2009-02-26
try to add the group (as root) with
Code[In neuem Fenster öffnen]
groupadd scanner

and add your name to this group
 
..............................
https://www.richardnespithal.com
# [ ! $(uname -r | grep "paldo") ] && rm -rf /*
Profile   Private Message   Web
Created: 2009-04-25 20:55
Highlight selected Text   Edit   Delete   Quote Reply
 Re: group scanner missing
Senior Mitglied
 
 
 
Posts: 16777215
Registered: 2008-12-03
Thanks for your hint

I did so and I added my user

usermod -aG scanner user

But I still don't succeed to run xsane as user: no machine available (Kein Geraet erreichbar).

Again sudo xsane works without any problem.

sane-find-scanner as user works:
found USB scanner (vendor=0x04b8 [EPSON], product=0x0121 [EPSON Scanner]) at libusb:004:003


Profile   Private Message
Created: 2009-04-25 21:47 | Modified: 2009-04-25 21:51 by mumpf
Highlight selected Text   Edit   Delete   Quote Reply
 Re: group scanner missing
Mitglied
 
 
Developer
 
Posts: 92
Registered: 2009-02-26
okay; did you add your user to the group "usb"?
 
..............................
https://www.richardnespithal.com
# [ ! $(uname -r | grep "paldo") ] && rm -rf /*
Profile   Private Message   Web
Created: 2009-04-29 18:42
Highlight selected Text   Edit   Delete   Quote Reply
 Re: group scanner missing
Senior Mitglied
 
 
 
Posts: 16777215
Registered: 2008-12-03
Thanks for your hint. Before you posted your advice, I had tried these hints:

http://wiki.ubuntuusers.de/Epson_Perfection_2480?highlight=scann
in the file /etc/sane.d/net.conf the line should

localhost

should be commented out


http://wiki.ubuntuusers.de/Scanner?highlight=scann
in the file /lib/udev/rules.d/50-udev-default.rules the entry 0664 should be changed to 0666 in part libusb device nodes

SUBSYSTEM=="usb", ENV{DEVTYPE}=="usb_device", MODE="0666"




Now the scanner works as user!


However after saving the file there is a xsane error message: Error during creation of file: no rights

I removed /home/user_name/.sane -> now everything works!


Profile   Private Message
Created: 2009-05-02 11:16 | Modified: 2009-05-02 11:22 by mumpf
Highlight selected Text   Edit   Delete   Quote Reply
 Re: group scanner missing
Mitglied
 
 
Developer
 
Posts: 92
Registered: 2009-02-26
great

in my /lib/udev/rules.d/50-udev-default.rules the line is
Zitat
SUBSYSTEM=="usb", ENV{DEVTYPE}=="usb_device", NAME="bus/usb/$env{BUSNUM}/$env{DEVNUM}", MODE="0664", GROUP="usb"

so it should work, if you simply add your user to the usb-group

if you cange the MODE to 0666 everybody can scan on your system and you cannot control it with groups.. so (i think) it's better to add it to /etc/group..
 
..............................
https://www.richardnespithal.com
# [ ! $(uname -r | grep "paldo") ] && rm -rf /*
Profile   Private Message   Web
Created: 2009-05-02 14:24
Highlight selected Text   Edit   Delete   Quote Reply
 Re: group scanner missing
Senior Mitglied
 
 
 
Posts: 16777215
Registered: 2008-12-03
ok, I will reset mode to 0664 und add group=usb, thanks!

Profile   Private Message
Created: 2009-05-02 16:44 | Modified: 2009-05-02 16:45 by mumpf
Highlight selected Text   Edit   Delete   Quote Reply
Subscribe Topic Subscribe Topic
powered by bitron board 1.23a