Package Search
 
Members: 353 | Topics: 767 | Posts: 3211
We welcome our newest member: ClintBarton
Info
» You aren't logged in, login or registerOnline: No members and 13 guests | Time: 00:44
Problem with coding HTML
paldo Support Forum    paldo    General Support
Reply Reply   Subscribe Topic Subscribe Topic
8 posts found.
 Problem with coding HTML
Mitglied
 
 
 
Posts: 56
Registered: 2007-11-13
Hello,
I have a programmer in html / php. Under windows I have the correct display in IE / Firefox. Out in Paldo, there are two things that are different : In a MySQL (SQL) it shows me an error conflicts with the Swedish and utf8 in a query.

And also i download jedit4.3pre16.jar and installed jdk and jre but it don't seem to want to install....

Can you give me a solution ?

Thanks
Profile   Private Message   E-Mail
Created: 2009-04-02 20:09 | Modified: 2009-04-03 10:46 by Paul75
Highlight selected Text   Edit   Delete   Quote Reply
 Re: Problem with coding HTML
Mitglied
 
 
Developer
 
Posts: 92
Registered: 2009-02-26
Zitat
In a MySQL (SQL) it shows me an error conflicts with the Swedish and utf8 in a query


Can you post the error-message here?

Zitat
And also i download jedit4.3pre16.jar and installed jdk and jre but it don't seem to want to install....

What do you want to install?
 
..............................
https://www.richardnespithal.com
# [ ! $(uname -r | grep "paldo") ] && rm -rf /*
Profile   Private Message   Web
Created: 2009-04-04 16:58
Highlight selected Text   Edit   Delete   Quote Reply
 Re: Problem with coding HTML
Mitglied
 
 
 
Posts: 56
Registered: 2007-11-13
Zitat
Original erstellt: 2009-04-04 16:58 von ritchy

What do you want to install?


Thanks for response.

I want to install jEdit. It is a program who can wrote php/html/js...

Thanks
Profile   Private Message   E-Mail
Created: 2009-04-04 17:29
Highlight selected Text   Edit   Delete   Quote Reply
 Re: Problem with coding HTML
Mitglied
 
 
 
Posts: 56
Registered: 2007-11-13
Hello,

The error of my SQL query is :

L'envoi de la requête a echoué, la Base de donnée a répondu :
Illegal mix of collations (latin1_swedish_ci,IMPLICIT) and (utf8_general_ci,COERCIBLE) for operation 'like'


And the SQL (into PHP script) :

$Query = "SELECT * FROM droits WHERE idrh='$idrh' AND module LIKE \"%".utf8_decode($item)."%\"";


It's a same problem with when i INSERT into a table the 'é', 'à', ..., are remplace by '?'.

Thanks

P.S. : The same script work perfectly into Debian or Ubuntu or Fedora.
Profile   Private Message   E-Mail
Created: 2009-04-04 20:31
Highlight selected Text   Edit   Delete   Quote Reply
 Re: Problem with coding HTML
Moderator
 
 
Linux-Dude
 
Posts: 1187
Registered: 2006-11-23
we don't support Swedish as language yet. So also mysql dosn't have the support. In what language do you write?
Profile   Private Message   E-Mail
Created: 2009-04-04 22:28
Highlight selected Text   Edit   Delete   Quote Reply
 Re: Problem with coding HTML
Mitglied
 
 
 
Posts: 56
Registered: 2007-11-13
Zitat
Original erstellt: 2009-04-04 22:28 von Amnon82
we don't support Swedish as language yet. So also mysql dosn't have the support. In what language do you write?


I wrote in PHP and I live in Paris (French)
Profile   Private Message   E-Mail
Created: 2009-04-04 22:43
Highlight selected Text   Edit   Delete   Quote Reply
 Re: Problem with coding HTML
Moderator
 
 
Linux-Dude
 
Posts: 1187
Registered: 2006-11-23
Profile   Private Message   E-Mail
Created: 2009-04-05 11:59 | Modified: 2009-04-05 11:59 by Amnon82
Highlight selected Text   Edit   Delete   Quote Reply
 Re: Problem with coding HTML
Mitglied
 
 
 
Posts: 56
Registered: 2007-11-13
Thanks. It means thats all my script can't work with paldo ?

Because I must havec latin1_swedish because in my server production is use it and now i can't change it....

Thanks
Profile   Private Message   E-Mail
Created: 2009-04-12 12:07
Highlight selected Text   Edit   Delete   Quote Reply
Subscribe Topic Subscribe Topic
powered by bitron board 1.23a