Package Search
 
Members: 353 | Topics: 767 | Posts: 3211
We welcome our newest member: ClintBarton
Info
» You aren't logged in, login or registerOnline: No members and 6 guests | Time: 18:21
paldo x86 testing - no gfx login after update!
paldo Support Forum    paldo    General Support
Reply Reply   Subscribe Topic Subscribe Topic
Help - no gfx login after updating system!
7 posts found.
 paldo x86 testing - no gfx login after update!
Mitglied
 
 
 
Posts: 78
Registered: 2008-08-16
Hi,
a bit earlier i've updated paldo as usual with: upkg-upgrade --verbose
and after a restart, the x server would no longer work.
I made a backup of the important files and re installed. The same thing happened again. After updating, no gfx login (just console)
This is new as for the past two weeks everything worked perfect.
My hardware was fully supported in all three branches (run unstable for a few days). The gfx card in this machine is a nvidia geforce 7 series.

Thanks :)
Profile   Private Message
Created: 2008-09-09 09:26 | Modified: 2008-09-09 09:35 by seanix
Highlight selected Text   Edit   Delete   Quote Reply
 Re: paldo x86 testing
Administrator
 
 
 
Posts: 426
Registered: 2004-09-09
The X server in testing has been updated to version 1.5.0. The NVIDIA driver should be compatible but it may still have bugs in this combination. Can you paste the contents of /var/log/Xorg.0.log?
Profile   Private Message   Web
Created: 2008-09-09 09:37
Highlight selected Text   Edit   Delete   Quote Reply
 Re: paldo x86 testing - no gfx login after update!
Mitglied
 
 
 
Posts: 78
Registered: 2008-08-16
Juerg,
thank you for responding :) In order to copy files off my home partition, i "temporary" installed another linux distro.
When I come home from work tonight, I will re-install paldo and paste what ever /var/log/Xorg.0.log tells me :)
I'll check this post before I re-install tonight just in case it got fixed.

Hi ho, hi ho, it's off to work i go ....
Profile   Private Message
Created: 2008-09-09 16:55
Highlight selected Text   Edit   Delete   Quote Reply
 Re: paldo x86 testing - no gfx login after update!
Moderator
 
 
Linux-Dude
 
Posts: 1187
Registered: 2006-11-23
I'm using also nvidia-gfx. Also I updated testing to the latest beta-driver. Should work, cos it works here.

Profile   Private Message   E-Mail
Created: 2008-09-10 01:12 | Modified: 2008-09-10 01:14 by Amnon82
Highlight selected Text   Edit   Delete   Quote Reply
 Re: paldo x86 testing - no gfx login after update!
Mitglied
 
 
 
Posts: 78
Registered: 2008-08-16
Hi agian,
I've just installed paldo 32 bit version, testing branch and it installed fine. The iso image i'm using to install is from August 19 and has been installed on a few machines without a problem.
When i update (sudo upkg-upgrade) it will now (as of this evening, 10 o'clock pacific time) reboot into x but only a blank screen with a terminal (x-term maybe?) at the left upper screen.
The gfx card in this machine is an nvidia 7600GT with 256MEG fo RAM

The Xorg.0.log after updating looks like this:


This is a pre-release version of the X server from The X.Org Foundation.
It is not supported in any way.
Bugs may be filed in the bugzilla at http://bugs.freedesktop.org/.
Select the "xorg" product for bugs you find in this release.
Before reporting bugs in pre-release versions please check the
latest version in the X.Org Foundation git repository.
See http://wiki.x.org/wiki/GitPage for git access instructions.

X.Org X Server 1.4.99.906 (1.5.0 RC 6)
Release Date:
X Protocol Version 11, Revision 0
Build Operating System: paldo
Current Operating System: Linux virgin 2.6.26.3-paldo2-x86 #1 SMP PREEMPT Sun Aug 24 15:27:26 CEST 2008 i686
Build Date: 23 July 2008 10:46:01PM

Before reporting problems, check http://wiki.x.org
to make sure that you have the latest version.
Module Loader present
Markers: (--) probed, (**) from config file, (==) default setting,
(++) from command line, (!!) notice, (II) informational,
(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.0.log", Time: Wed Sep 10 04:43:07 2008
(==) Using config file: "/etc/X11/xorg.conf"
(**) Option "defaultserverlayout" "Default"
(**) ServerLayout "Default"
(**) |-->Screen "Screen0" (0)
(**) | |-->Monitor "<default monitor>"
(**) | |-->Device "Card0"
(==) No monitor specified for screen "Screen0".
Using a default monitor configuration.
(**) Option "AllowEmptyInput"
(==) Automatically adding devices
(==) Automatically enabling devices
(==) No FontPath specified. Using compiled-in default.
(==) FontPath set to:
/usr/share/X11/fonts/misc/
(==) ModulePath set to "/usr/lib/xorg/modules"
(WW) Open ACPI failed (/var/run/acpid.socket) (No such file or directory)
(II) No APM support in BIOS or kernel
(II) Loader magic: 0x81ca4c0
(II) Module ABI versions:
X.Org ANSI C Emulation: 0.4
X.Org Video Driver: 4.1
X.Org XInput driver : 2.1
X.Org Server Extension : 1.1
X.Org Font Renderer : 0.6
(II) Loader running on linux
(--) using VT number 2

(--) PCI:*(0@2:0:0) nVidia Corporation G70 [GeForce 7600 GT] rev 161, Mem @ 0xfa000000/0, 0xe0000000/0, 0xfb000000/0, I/O @ 0x00009c00/0, BIOS @ 0x????????/131072
(--) PCI: (0@3:10:0) Internext Compression Inc iTVC16 (CX23416) MPEG-2 Encoder rev 1, Mem @ 0xf4000000/0
(II) System resource ranges:
[0] -1 0 0xffffffff - 0xffffffff (0x1) MX
[1] -1 0 0x000f0000 - 0x000fffff (0x10000) MX
[2] -1 0 0x000c0000 - 0x000effff (0x30000) MX
[3] -1 0 0x00000000 - 0x0009ffff (0xa0000) MX
[4] -1 0 0xffffffff - 0xffffffff (0x1) MX
[5] -1 0 0x000f0000 - 0x000fffff (0x10000) MX
[6] -1 0 0x000c0000 - 0x000effff (0x30000) MX
[7] -1 0 0x00000000 - 0x0009ffff (0xa0000) MX
[8] -1 0 0xffffffff - 0xffffffff (0x1) MX
[9] -1 0 0x000f0000 - 0x000fffff (0x10000) MX
[10] -1 0 0x000c0000 - 0x000effff (0x30000) MX
[11] -1 0 0x00000000 - 0x0009ffff (0xa0000) MX
[12] -1 0 0xffffffff - 0xffffffff (0x1) MX
[13] -1 0 0x000f0000 - 0x000fffff (0x10000) MX
[14] -1 0 0x000c0000 - 0x000effff (0x30000) MX
[15] -1 0 0x00000000 - 0x0009ffff (0xa0000) MX
[16] -1 0 0x0000ffff - 0x0000ffff (0x1) IX
[17] -1 0 0x00000000 - 0x00000000 (0x1) IX
[18] -1 0 0x0000ffff - 0x0000ffff (0x1) IX
[19] -1 0 0x00000000 - 0x00000000 (0x1) IX
[20] -1 0 0x0000ffff - 0x0000ffff (0x1) IX
[21] -1 0 0x00000000 - 0x00000000 (0x1) IX
[22] -1 0 0x0000ffff - 0x0000ffff (0x1) IX
[23] -1 0 0x00000000 - 0x00000000 (0x1) IX
(II) "extmod" will be loaded. This was enabled by default and also specified in the config file.
(II) "dbe" will be loaded. This was enabled by default and also specified in the config file.
(II) "glx" will be loaded. This was enabled by default and also specified in the config file.
(II) "freetype" will be loaded. This was enabled by default and also specified in the config file.
(II) "dri" will be loaded. This was enabled by default and also specified in the config file.
(II) LoadModule: "extmod"

(II) Loading /usr/lib/xorg/modules/extensions//libextmod.so
(II) Module extmod: vendor="X.Org Foundation"
compiled for 1.4.99.906, module version = 1.0.0
Module class: X.Org Server Extension
ABI class: X.Org Server Extension, version 1.1
(II) Loading extension SHAPE
(II) Loading extension MIT-SUNDRY-NONSTANDARD
(II) Loading extension BIG-REQUESTS
(II) Loading extension SYNC
(II) Loading extension MIT-SCREEN-SAVER
(II) Loading extension XC-MISC
(II) Loading extension XFree86-VidModeExtension
(II) Loading extension XFree86-Misc
(II) Loading extension XFree86-DGA
(II) Loading extension DPMS
(II) Loading extension TOG-CUP
(II) Loading extension Extended-Visual-Information
(II) Loading extension XVideo
(II) Loading extension XVideo-MotionCompensation
(II) Loading extension X-Resource
(II) LoadModule: "glx"

(II) Loading /usr/lib/xorg/modules/extensions//libglx.so
(II) Module glx: vendor="NVIDIA Corporation"
compiled for 4.0.2, module version = 1.0.0
Module class: X.Org Server Extension
(II) NVIDIA GLX Module 177.68 Tue Aug 19 21:10:09 PDT 2008
(II) Loading extension GLX
(II) LoadModule: "dri"

(II) Loading /usr/lib/xorg/modules/extensions//libdri.so
(II) Module dri: vendor="X.Org Foundation"
compiled for 1.4.99.906, module version = 1.0.0
ABI class: X.Org Server Extension, version 1.1
(II) Loading extension XFree86-DRI
(II) LoadModule: "dbe"

(II) Loading /usr/lib/xorg/modules/extensions//libdbe.so
(II) Module dbe: vendor="X.Org Foundation"
compiled for 1.4.99.906, module version = 1.0.0
Module class: X.Org Server Extension
ABI class: X.Org Server Extension, version 1.1
(II) Loading extension DOUBLE-BUFFER
(II) LoadModule: "record"

(WW) Warning, couldn't open module record
(II) UnloadModule: "record"
(EE) Failed to load module "record" (module does not exist, 0)
(II) LoadModule: "freetype"

(II) Loading /usr/lib/xorg/modules/fonts//libfreetype.so
(II) Module freetype: vendor="X.Org Foundation & the After X-TT Project"
compiled for 1.4.99.906, module version = 2.1.0
Module class: X.Org Font Renderer
ABI class: X.Org Font Renderer, version 0.6
(II) Loading font FreeType
(II) LoadModule: "type1"

(WW) Warning, couldn't open module type1
(II) UnloadModule: "type1"
(EE) Failed to load module "type1" (module does not exist, 0)
(II) LoadModule: "nvidia"

(II) Loading /usr/lib/xorg/modules/drivers//nvidia_drv.so
(II) Module nvidia: vendor="NVIDIA Corporation"
compiled for 4.0.2, module version = 1.0.0
Module class: X.Org Video Driver
(II) NVIDIA dlloader X Driver 177.68 Tue Aug 19 20:48:20 PDT 2008
(II) NVIDIA Unified Driver for all Supported NVIDIA GPUs
(II) Primary Device is: PCI 02@00:00:0
(II) Loading sub module "fb"
(II) LoadModule: "fb"

(II) Loading /usr/lib/xorg/modules//libfb.so
(II) Module fb: vendor="X.Org Foundation"
compiled for 1.4.99.906, module version = 1.0.0
ABI class: X.Org ANSI C Emulation, version 0.4
(II) Loading sub module "wfb"
(II) LoadModule: "wfb"

(II) Loading /usr/lib/xorg/modules//libwfb.so
(II) Module wfb: vendor="X.Org Foundation"
compiled for 1.4.99.906, module version = 1.0.0
ABI class: X.Org ANSI C Emulation, version 0.4
(II) Loading sub module "ramdac"
(II) LoadModule: "ramdac"
(II) Module "ramdac" already built-in
(II) resource ranges after probing:
[0] -1 0 0xffffffff - 0xffffffff (0x1) MX
[1] -1 0 0x000f0000 - 0x000fffff (0x10000) MX
[2] -1 0 0x000c0000 - 0x000effff (0x30000) MX
[3] -1 0 0x00000000 - 0x0009ffff (0xa0000) MX
[4] -1 0 0xffffffff - 0xffffffff (0x1) MX
[5] -1 0 0x000f0000 - 0x000fffff (0x10000) MX
[6] -1 0 0x000c0000 - 0x000effff (0x30000) MX
[7] -1 0 0x00000000 - 0x0009ffff (0xa0000) MX
[8] -1 0 0xffffffff - 0xffffffff (0x1) MX
[9] -1 0 0x000f0000 - 0x000fffff (0x10000) MX
[10] -1 0 0x000c0000 - 0x000effff (0x30000) MX
[11] -1 0 0x00000000 - 0x0009ffff (0xa0000) MX
[12] -1 0 0xffffffff - 0xffffffff (0x1) MX
[13] -1 0 0x000f0000 - 0x000fffff (0x10000) MX
[14] -1 0 0x000c0000 - 0x000effff (0x30000) MX
[15] -1 0 0x00000000 - 0x0009ffff (0xa0000) MX
[16] -1 0 0x0000ffff - 0x0000ffff (0x1) IX
[17] -1 0 0x00000000 - 0x00000000 (0x1) IX
[18] -1 0 0x0000ffff - 0x0000ffff (0x1) IX
[19] -1 0 0x00000000 - 0x00000000 (0x1) IX
[20] -1 0 0x0000ffff - 0x0000ffff (0x1) IX
[21] -1 0 0x00000000 - 0x00000000 (0x1) IX
[22] -1 0 0x0000ffff - 0x0000ffff (0x1) IX
[23] -1 0 0x00000000 - 0x00000000 (0x1) IX
(II) NVIDIA(0): Creating default Display subsection in Screen section
"Screen0" for depth/fbbpp 24/32
(==) NVIDIA(0): Depth 24, (==) framebuffer bpp 32
(==) NVIDIA(0): RGB weight 888
(==) NVIDIA(0): Default visual is TrueColor
(==) NVIDIA(0): Using gamma correction (1.0, 1.0, 1.0)
(**) NVIDIA(0): Enabling RENDER acceleration
(II) NVIDIA(0): Support for GLX with the Damage and Composite X extensions is
(II) NVIDIA(0): enabled.
(II) NVIDIA(0): NVIDIA GPU GeForce 7600 GT (G73) at PCI:2:0:0 (GPU-0)
(--) NVIDIA(0): Memory: 262144 kBytes
(--) NVIDIA(0): VideoBIOS: 05.73.22.18.08
(II) NVIDIA(0): Detected PCI Express Link width: 16X
(--) NVIDIA(0): Interlaced video modes are supported on this GPU
(--) NVIDIA(0): Connected display device(s) on GeForce 7600 GT at PCI:2:0:0:
(--) NVIDIA(0): Gateway FPD2185W (CRT-0)
(--) NVIDIA(0): Gateway FPD2185W (CRT-0): 400.0 MHz maximum pixel clock
(II) NVIDIA(0): Assigned Display Device: CRT-0
(==) NVIDIA(0):
(==) NVIDIA(0): No modes were requested; the default mode "nvidia-auto-select"
(==) NVIDIA(0): will be used as the requested mode.
(==) NVIDIA(0):
(II) NVIDIA(0): Validated modes:
(II) NVIDIA(0): "nvidia-auto-select"
(II) NVIDIA(0): Virtual screen size determined to be 1680 x 1050
(--) NVIDIA(0): DPI set to (94, 95); computed from "UseEdidDpi" X config
(--) NVIDIA(0): option
(==) NVIDIA(0): Enabling 32-bit ARGB GLX visuals.
(--) Depth 24 pixmap format is 32 bpp
(II) do I need RAC? No, I don't.
(II) resource ranges after preInit:
[0] -1 0 0xffffffff - 0xffffffff (0x1) MX
[1] -1 0 0x000f0000 - 0x000fffff (0x10000) MX
[2] -1 0 0x000c0000 - 0x000effff (0x30000) MX
[3] -1 0 0x00000000 - 0x0009ffff (0xa0000) MX
[4] -1 0 0xffffffff - 0xffffffff (0x1) MX
[5] -1 0 0x000f0000 - 0x000fffff (0x10000) MX
[6] -1 0 0x000c0000 - 0x000effff (0x30000) MX
[7] -1 0 0x00000000 - 0x0009ffff (0xa0000) MX
[8] -1 0 0xffffffff - 0xffffffff (0x1) MX
[9] -1 0 0x000f0000 - 0x000fffff (0x10000) MX
[10] -1 0 0x000c0000 - 0x000effff (0x30000) MX
[11] -1 0 0x00000000 - 0x0009ffff (0xa0000) MX
[12] -1 0 0xffffffff - 0xffffffff (0x1) MX
[13] -1 0 0x000f0000 - 0x000fffff (0x10000) MX
[14] -1 0 0x000c0000 - 0x000effff (0x30000) MX
[15] -1 0 0x00000000 - 0x0009ffff (0xa0000) MX
[16] -1 0 0x0000ffff - 0x0000ffff (0x1) IX
[17] -1 0 0x00000000 - 0x00000000 (0x1) IX
[18] -1 0 0x0000ffff - 0x0000ffff (0x1) IX
[19] -1 0 0x00000000 - 0x00000000 (0x1) IX
[20] -1 0 0x0000ffff - 0x0000ffff (0x1) IX
[21] -1 0 0x00000000 - 0x00000000 (0x1) IX
[22] -1 0 0x0000ffff - 0x0000ffff (0x1) IX
[23] -1 0 0x00000000 - 0x00000000 (0x1) IX
(II) NVIDIA(0): Initialized GPU GART.
(II) NVIDIA(0): Unable to connect to the ACPI daemon; the ACPI daemon may not
(II) NVIDIA(0): be running or the "AcpidSocketPath" X configuration option
(II) NVIDIA(0): may not be set correctly. When the ACPI daemon is
(II) NVIDIA(0): available, the NVIDIA X driver can use it to receive ACPI
(II) NVIDIA(0): events. For details, please see the "ConnectToAcpid" and
(II) NVIDIA(0): "AcpidSocketPath" X configuration options in Appendix B: X
(II) NVIDIA(0): Config Options in the README.
(II) NVIDIA(0): Setting mode "nvidia-auto-select"
(II) Loading extension NV-GLX
(II) NVIDIA(0): NVIDIA 3D Acceleration Architecture Initialized
(II) NVIDIA(0): Using the NVIDIA 2D acceleration architecture
(==) NVIDIA(0): Backing store disabled
(==) NVIDIA(0): Silken mouse enabled
(II) NVIDIA(0): DPMS enabled
(II) Loading extension NV-CONTROL
(II) Loading extension XINERAMA
(==) RandR enabled
(II) Initializing built-in extension MIT-SHM
(II) Initializing built-in extension XInputExtension
(II) Initializing built-in extension XTEST
(II) Initializing built-in extension XKEYBOARD
(II) Initializing built-in extension XINERAMA
(II) Initializing built-in extension XFIXES
(II) Initializing built-in extension RENDER
(II) Initializing built-in extension RANDR
(II) Initializing built-in extension COMPOSITE
(II) Initializing built-in extension DAMAGE
(II) Initializing built-in extension XEVIE
(II) Initializing extension GLX
(II) config/hal: Adding input device ImExPS/2 Generic Explorer Mouse
(II) LoadModule: "evdev"

(II) Loading /usr/lib/xorg/modules/input//evdev_drv.so
(II) Module evdev: vendor="X.Org Foundation"
compiled for 1.4.99.906, module version = 2.0.4
Module class: X.Org XInput Driver
ABI class: X.Org XInput driver, version 2.1
(**) ImExPS/2 Generic Explorer Mouse: always reports core events
(**) ImExPS/2 Generic Explorer Mouse: Device: "/dev/input/event3"
(II) ImExPS/2 Generic Explorer Mouse: Found x and y relative axes
(II) ImExPS/2 Generic Explorer Mouse: Found mouse buttons
(II) ImExPS/2 Generic Explorer Mouse: Configuring as mouse
(II) XINPUT: Adding extended input device "ImExPS/2 Generic Explorer Mouse" (type: MOUSE)
(II) config/hal: Adding input device AT Translated Set 2 keyboard
(**) AT Translated Set 2 keyboard: always reports core events
(**) AT Translated Set 2 keyboard: Device: "/dev/input/event2"
(II) AT Translated Set 2 keyboard: Found keys
(II) AT Translated Set 2 keyboard: Configuring as keyboard
(II) XINPUT: Adding extended input device "AT Translated Set 2 keyboard" (type: KEYBOARD)
(**) Option "xkb_rules" "base"
(**) AT Translated Set 2 keyboard: xkb_rules: "base"
(**) Option "xkb_model" "evdev"
(**) AT Translated Set 2 keyboard: xkb_model: "evdev"
(**) Option "xkb_layout" "ch"
(**) AT Translated Set 2 keyboard: xkb_layout: "ch"
(**) Option "xkb_variant" "de_nodeadkeys"
(**) AT Translated Set 2 keyboard: xkb_variant: "de_nodeadkeys"

=======================================================================
I also saved the same log "before" updating as well.

I hope there is a solution to this as I've installed "unstable" temporary until the testing branch is fixed. Unstable updates fine ... strange!
Profile   Private Message
Created: 2008-09-10 07:24
Highlight selected Text   Edit   Delete   Quote Reply
 Re: paldo x86 testing - no gfx login after update!
Administrator
 
 
 
Posts: 426
Registered: 2004-09-09
Something is really strange here. The X server you're using according to your logs is the paldo unstable build of the prerelease 1.4.99.906. This version was never in paldo testing, and both, paldo testing and unstable, already have X server 1.5.0 for almost five days now. Also the kernel version 2.6.26.3-paldo2 is not what is currently in paldo.

Is it possible that you've upgraded using a local mirror of paldo.org that has not been synchronized for some days?
Profile   Private Message   Web
Created: 2008-09-10 07:37
Highlight selected Text   Edit   Delete   Quote Reply
 Re: paldo x86 testing - no gfx login after update!
Mitglied
 
 
 
Posts: 78
Registered: 2008-08-16
Juerg,
how about this: I will download a new "testing" iso tomorrow, install it and see what happens. Since no one else had a problem, I assume there is something odd happening on my end.
I had a hard day and it is possible that i have made a mistake installing the "wrong" image because i had to re install a few times since my password would not work (which was strange in itself) and therefore, a mix up could have happened ... maybe.
For now, let's assume the the error lies between monitor and chair ;)

Just one last thing, i do run unstable (temporary) and it works perfectly. But tomorrow i'll know more.
Profile   Private Message
Created: 2008-09-10 08:52
Highlight selected Text   Edit   Delete   Quote Reply
Subscribe Topic Subscribe Topic
powered by bitron board 1.23a