Package Search
 
Members: 353 | Topics: 767 | Posts: 3211
We welcome our newest member: ClintBarton
Info
» You aren't logged in, login or registerOnline: No members and 3 guests | Time: 12:57
Banshee doesn't start
paldo Support Forum    paldo    General Support
Reply Reply   Subscribe Topic Subscribe Topic
Banshee catches an unhandled exception when started
19 posts found.Page: 1 2
This topic contains previous posts. Back
 Re: Banshee doesn't start
Mitglied
 
 
 
Posts: 70
Registered: 2008-08-24
My approach would be cleaner (let ipod-sharp package do it's stuff by itself). Moreover if I don't want Banshee but only the library I keep being stucked because the library isn't registered in the GAC. Can you please try it?
 
..............................
Running GNU/Linux Paldo 1.18 (unstable). Rock my box!
Profile   Private Message   Web
Created: 2008-08-28 18:32 | Modified: 2008-08-28 18:34 by axelgenus
Highlight selected Text   Edit   Delete   Quote Reply
 Re: Banshee doesn't start
Moderator
 
 
Linux-Dude
 
Posts: 1187
Registered: 2006-11-23
postinst is for cmds after a complete build. If I call the cmds in the build-scripts the installed dlls get removed during a uninstall of banshee otherwise not. Also you need always full paths:

Code[In neuem Fenster öffnen]
<postinst>
<!-- unregistring old ipod-sharp if any -->
<cmd>gacutil -u ipod-sharp</cmd>
<cmd>gacutil -u ipod-sharp-ui</cmd>
<!-- registring ipod-sharp -->
<cmd>gacutil -i /usr/lib/banshee-1/Extensions/ipod-sharp.dll</cmd>
<cmd>gacutil -i /usr/lib/banshee-1/Extensions/ipod-sharp-ui.dll</cmd>
</postinst>
Profile   Private Message   E-Mail
Created: 2008-08-28 18:38
Highlight selected Text   Edit   Delete   Quote Reply
 Re: Banshee doesn't start
Mitglied
 
 
 
Posts: 70
Registered: 2008-08-24
Zitat
Original erstellt: 2008-08-28 18:38 von Amnon82
postinst is for cmds after a complete build.

Shoudn't that be "postbuild"?

Following the man page the commands in the <build> tags should "explain" upkg about building the package and not what to do after its installation. I'm going to try locally...
 
..............................
Running GNU/Linux Paldo 1.18 (unstable). Rock my box!
Profile   Private Message   Web
Created: 2008-08-28 18:44 | Modified: 2008-08-28 18:45 by axelgenus
Highlight selected Text   Edit   Delete   Quote Reply
 Re: Banshee doesn't start
Moderator
 
 
Linux-Dude
 
Posts: 1187
Registered: 2006-11-23
well it works here now. asked juerg what case it right. build or postinst. Will update the spec if needed to postinst version.
Profile   Private Message   E-Mail
Created: 2008-08-28 18:45
Highlight selected Text   Edit   Delete   Quote Reply
 Re: Banshee doesn't start
Moderator
 
 
Linux-Dude
 
Posts: 1187
Registered: 2006-11-23
after the cmd "make install" the build is finished. If you add some more cmds after it it will be done after. So it is always after. Postinst is only for cmds upkg will delete like la-files. Take a look on some kde-packages.
Profile   Private Message   E-Mail
Created: 2008-08-28 18:50
Highlight selected Text   Edit   Delete   Quote Reply
 Re: Banshee doesn't start
Mitglied
 
 
 
Posts: 70
Registered: 2008-08-24
Zitat
Original erstellt: 2008-08-28 18:50 von Amnon82
after the cmd "make install" the build is finished. If you add some more cmds after it it will be done after.

Yes it works this way but those commands will be only executed on the computer which builds the package and not on the one I will install it from the repository.

I don't know if "postinst" tag is the right one. I assume it means "commands which will be executed after install (upkg-install)".
 
..............................
Running GNU/Linux Paldo 1.18 (unstable). Rock my box!
Profile   Private Message   Web
Created: 2008-08-28 19:01 | Modified: 2008-08-28 19:02 by axelgenus
Highlight selected Text   Edit   Delete   Quote Reply
 Re: Banshee doesn't start
Moderator
 
 
Linux-Dude
 
Posts: 1187
Registered: 2006-11-23
Well postinst will be executed only locally. You're right. In this case it doesn't matter. I uninstalled the modules and removed banshee completely.
Then I installed the new one from the repo.

Also I installed banshee on my laptop. It was a fresh install. No problems at all.
So it works the way I committed the last spec for banshee.
Profile   Private Message   E-Mail
Created: 2008-08-28 22:04
Highlight selected Text   Edit   Delete   Quote Reply
 Re: Banshee doesn't start
Mitglied
 
 
 
Posts: 70
Registered: 2008-08-24
Ok, it works here too. Thanks.
 
..............................
Running GNU/Linux Paldo 1.18 (unstable). Rock my box!
Profile   Private Message   Web
Created: 2008-08-29 08:04
Highlight selected Text   Edit   Delete   Quote Reply
 Re: Banshee doesn't start
Moderator
 
 
Linux-Dude
 
Posts: 1187
Registered: 2006-11-23
ur welcome
Profile   Private Message   E-Mail
Created: 2008-08-29 21:54
Highlight selected Text   Edit   Delete   Quote Reply
Page: 1 2
Subscribe Topic Subscribe Topic
powered by bitron board 1.23a