Package Search
 
Members: 351 | Topics: 765 | Posts: 3209
We welcome our newest member: Somewhat Reticent
Info
» You aren't logged in, login or registerOnline: No members and 4 guests | Time: 02:29
Blender scripts incompatible with NLS
paldo Support Forum    Upkg    Package Specifications
Reply Reply   Subscribe Topic Subscribe Topic
1 post found.
 Blender scripts incompatible with NLS
Senior Mitglied
 
 
 
Posts: 216
Registered: 2008-07-04
hi everyone, I've been struggling to make yafaray work on most of the distributions, paldo is no exception

So Some of my scripts and yafaray in special made blender crash with segmentation fault.

From the output most of the people think it is related to QT4, because it segfaults right after the line : Creating QApplication.

The QT is not the problem, the problem is blender and nls, for some reason I still don't know, it makes some scripts crash or not function correctly, this happens on opensuse, fedora, gentoo, mandriva and others.

To fix this problem we need to disable the INTERNATIONAL option from blender and not install the files related so the correct spec for blender would be:

Code[In neuem Fenster öffnen]
<?xml version="1.0"?>
<package name="blender">
<description>free 3d modeller and renderer</description>
<releases>
<!-- http://www.blender.org -->
<!-- Maintainer: Richard Nespithal -->
<!-- Modified by Diogo Lima on Jun 6 2010 -->
<release version="2.49a" revision="3" branch="testing">
<deps>
<dep name="x11"/>
<dep name="xext"/>
<dep name="xxf86vm"/>
<dep name="freetype"/>
<dep name="SDL"/>
<dep name="Python"/>
<dep name="jpeg"/>
<dep name="libpng"/>
<dep name="zlib"/>
<dep name="openal"/>
<dep name="scons"/>
<dep name="freealut"/>
<dep name="openexr"/>
<dep name="ffmpeg"/>
<dep name="gettext"/>
<dep name="mesa"/>
</deps>
<build>
<script>
<archive name="blender-$VERSION">
<cmd>scons -j 2 BF_PYTHON_VERSION=2.6 BF_BUILDDIR=blender-build BF_INSTALLDIR=blender-install WITH_BF_GAMEENGINE=true WITH_BF_FREETYPE=true WITH_BF_INTERNATIONAL=false</cmd>
<cmd>install -D -m 755 blender-install/blender /usr/bin/blender-bin</cmd>
<cmd>mkdir -p /usr/lib/blender</cmd>
<!-- rm old rls -->
<cmd>rm -rfv /usr/lib/blender/*</cmd>
<!--<cmd>cp -a blender-install/.blender/{locale,scripts} blender-install/plugins /usr/lib/blender</cmd>-->
<cmd>cp -a blender-install/.blender/scripts blender-install/plugins /usr/lib/blender</cmd>
<!--<cmd>install -m 644 blender-install/.blender/.Blanguages /usr/lib/blender</cmd>-->
<!--<cmd>install -m 644 blender-install/.blender/.bfont.ttf /usr/lib/blender</cmd>-->

<cmd check="no">cat &gt; /usr/share/applications/blender.desktop &lt;&lt; "EOF"
[Desktop Entry]
Name=Blender 3D Modeller
Comment=Create and edit 3D models and animations
Exec=blender
Icon=blender
Terminal=false
Type=Application
Categories=Application;Graphics;
StartupNotify=false
MimeType=application/x-blender;
EOF</cmd>
<cmd>install -D release/freedesktop/icons/scalable/blender.svg /usr/share/pixmaps/blender.svg</cmd>

<!-- Blender Start Script -->
<text dest="/usr/bin/blender" mode="755"><![CDATA;then
blender-bin "$@"
fi
}
blenderstarter "$@"
]]></text>
</archive>
</script>
</build>
</release>
</releases>
</package>



The modifications are in BOLD.

So summarizing:

    change BF_INTERNATIONAL=true to BF_INTERNATION=false
    do not install locale .Blanguages or .bfont.ttf


This should fix the misbehaving of some blender python scripts
 
..............................
OSs: Paldo-testing x86_64 :: HP Pavilion dv9680ez
Profile   Private Message   E-Mail
Created: 2010-06-06 18:33
Highlight selected Text   Edit   Delete   Quote Reply
Subscribe Topic Subscribe Topic
powered by bitron board 1.23a