Package Search
 
Members: 351 | Topics: 766 | Posts: 3210
We welcome our newest member: Somewhat Reticent
Info
» You aren't logged in, login or registerOnline: No members and 4 guests | Time: 12:19
Blender doesn't work
paldo Support Forum    Upkg    General Discussion
Reply Reply   Subscribe Topic Subscribe Topic
can't find libGL.so.1
5 posts found.
 Blender doesn't work
Senior Mitglied
 
 
 
Posts: 216
Registered: 2008-07-04
Blender doesn't work:

blender-bin: error while loading shared libraries: libGL.so.1: cannot open shared object file: No such file or directory

libGL.so exists on /usr/lib/libGL.so, but thereis no libGL.so.1 (which should be a symlink, creating the symlink doesn't work)

Trying to rebuild it now
 
..............................
OSs: Paldo-testing x86_64 :: HP Pavilion dv9680ez
Profile   Private Message   E-Mail
Created: 2010-06-06 17:16
Highlight selected Text   Edit   Delete   Quote Reply
 missing libGL.so.1
Senior Mitglied
 
 
 
Posts: 216
Registered: 2008-07-04
The problem seems to be on every 3D application here is the ldd for glxgears:


[diogo@hp-laptop:~]$ ldd /usr/bin/glxgears
linux-vdso.so.1 => (0x00007fffe5973000)
libGL.so.1 => not found
libm.so.6 => /lib/libm.so.6 (0x00007fd1ba5ac000)
libX11.so.6 => /usr/lib/libX11.so.6 (0x00007fd1ba271000)
libpthread.so.0 => /lib/libpthread.so.0 (0x00007fd1ba055000)
libc.so.6 => /lib/libc.so.6 (0x00007fd1b9cfe000)
libxcb.so.1 => /usr/lib/libxcb.so.1 (0x00007fd1b9ae1000)
libdl.so.2 => /lib/libdl.so.2 (0x00007fd1b98dd000)
/lib/ld-linux-x86-64.so.2 (0x00007fd1ba82d000)
libXau.so.6 => /usr/lib/libXau.so.6 (0x00007fd1b96da000)
libXdmcp.so.6 => /usr/lib/libXdmcp.so.6 (0x00007fd1b94d5000)

 
..............................
OSs: Paldo-testing x86_64 :: HP Pavilion dv9680ez
Profile   Private Message   E-Mail
Created: 2010-06-06 17:21
Highlight selected Text   Edit   Delete   Quote Reply
 Re: Blender doesn't work
Senior Mitglied
 
 
 
Posts: 216
Registered: 2008-07-04
Found the problem

For some reason the symlink from /usr/lib/libGL.so.1 to /usr/lib/mesa/libGL.so.1 is not present on my system... fixed doing:

Code[In neuem Fenster öffnen]
sudo ln -sv mesa/libGL.so.1 libGL.so.1


The mesa binary doesn't have the /usr/lib/libGL.so.1 symlink on it so this might have been the source of my problem. (The postinst wasn't correctly done, don't know why)

I still have a problem:
Compiled with Python version 2.6.2.
Checking for installed Python... got it!
intern/ghost/intern/GHOST_WindowX11.cpp:177: X11 glxChooseVisual() failed for OpenGL, verify working openGL system!
X Error of failed request: BadWindow (invalid Window parameter)
Major opcode of failed request: 18 (X_ChangeProperty)
Resource id in failed request: 0xd30a06f0
Serial number of failed request: 33
Current serial number in output stream: 34


Blender doesn't work
 
..............................
OSs: Paldo-testing x86_64 :: HP Pavilion dv9680ez
Profile   Private Message   E-Mail
Created: 2010-06-06 17:29 | Modified: 2010-06-06 17:32 by diogo
Highlight selected Text   Edit   Delete   Quote Reply
 Re: Blender doesn't work
Administrator
 
 
 
Posts: 426
Registered: 2004-09-09
You're using nvidia-glx, right? Have you been doing any experiments with installing the nvidia driver without upkg or something similar? Or are you starting X without gdm?
Profile   Private Message   Web
Created: 2010-06-06 17:30
Highlight selected Text   Edit   Delete   Quote Reply
 Re: Blender doesn't work
Senior Mitglied
 
 
 
Posts: 216
Registered: 2008-07-04
I just saw that there were something wrong with nvidia installation reinstalling it... (I posted earlier a problem concerning nvidia driver not working because of wrong modulepath)

I'm reinstalling nvidia-glx to try to get it working

FOR somereason nvidia-glx got uninstalled but nvidia-glx-$TAG didn't so I didn't notice it

COMPLETED and SOLVED
 
..............................
OSs: Paldo-testing x86_64 :: HP Pavilion dv9680ez
Profile   Private Message   E-Mail
Created: 2010-06-06 17:37 | Modified: 2010-06-06 17:40 by diogo
Highlight selected Text   Edit   Delete   Quote Reply
Subscribe Topic Subscribe Topic
powered by bitron board 1.23a