Package Search
 
Members: 351 | Topics: 766 | Posts: 3210
We welcome our newest member: Somewhat Reticent
Info
» You aren't logged in, login or registerOnline: No members and 4 guests | Time: 02:19
upkg error - cannot install or upgrade
paldo Support Forum    paldo    Paldo 1.15 LinuxUser Support Forum
Reply Reply   Subscribe Topic Subscribe Topic
I just Installed The newest paldo iso, and am having trouble with upkg.
13 posts found.Page: 1 2
 upkg error - cannot install or upgrade
Junior Mitglied
 
 
 
Posts: 4
Registered: 2010-04-11
I just Installed The newest paldo iso, and am having trouble with upkg.
when I try to install OR upgrade (packages) I get this:


[root@utilitop:~]# upkg-install emacs
Generating script...

Unhandled Exception: System.NullReferenceException: Object reference not set to an instance of an object
at Upkg.XmlSpecification.CachedWebDownload (System.String remotefile, System.String localfile) [0x00000]
at Upkg.XmlSpecification..ctor (System.String file) [0x00000]
at Upkg.Package..ctor (System.String name, Boolean allowZombies) [0x00000]
at Upkg.Package.GetPackage (System.String name, Boolean allowZombies) [0x00000]
at Upkg.Package.GetPackage (System.String name) [0x00000]
at Upkg.ReleaseSpecification.ProcessDeps (System.Xml.XmlElement depsElement) [0x00000]
at Upkg.ReleaseSpecification.Process () [0x00000]
at Upkg.Branches.get_Item (System.Object key) [0x00000]
at Upkg.Branches.get_Current () [0x00000]
at Upkg.ReleaseSpecification.ProcessDeps (System.Xml.XmlElement depsElement) [0x00000]
at Upkg.ReleaseSpecification.Process () [0x00000]
at Upkg.Branches.get_Item (System.Object key) [0x00000]
at Upkg.Branches.get_Current () [0x00000]
at Upkg.ReleaseList.AddRelease (System.String packageName, System.String tag, Boolean allowZombies) [0x00000]
at Upkg.ReleaseList.AddRelease (System.String packageName, System.String tag) [0x00000]
at Upkg.Application.Main (System.String[] args) [0x00000]
Could not generate script!


The same error occurs if i do upkg-upgrade as well.
I tried flushing my cache (deleting /var/cache/upkg/*) AND doing upkg-upgrade right after with no luck. Any ideas?
Profile   Private Message
Created: 2010-04-11 21:56
Highlight selected Text   Edit   Delete   Quote Reply
 Re: upkg error - cannot install or upgrade
Mitglied
 
 
 
Posts: 73
Registered: 2009-07-15
try this

[root@utilitop:~]# sudo upkg-install emacs

instead of

[root@utilitop:~]# upkg-install emacs
Profile   Private Message
Created: 2010-04-11 23:37
Highlight selected Text   Edit   Delete   Quote Reply
 [root@utilitop:/home/utilis]# sudo upkg-install em
Junior Mitglied
 
 
 
Posts: 4
Registered: 2010-04-11
[root@utilitop:/home/utilis]# sudo upkg-install emacs
Generating script...

Unhandled Exception: System.NullReferenceException: Object reference not set to an instance of an object
at Upkg.XmlSpecification.CachedWebDownload (System.String remotefile, System.String localfile) [0x00000]
at Upkg.XmlSpecification..ctor (System.String file) [0x00000]
at Upkg.Package..ctor (System.String name, Boolean allowZombies) [0x00000]
at Upkg.Package.GetPackage (System.String name, Boolean allowZombies) [0x00000]
at Upkg.Package.GetPackage (System.String name) [0x00000]
at Upkg.ReleaseSpecification.ProcessDeps (System.Xml.XmlElement depsElement) [0x00000]
at Upkg.ReleaseSpecification.Process () [0x00000]
at Upkg.Branches.get_Item (System.Object key) [0x00000]
at Upkg.Branches.get_Current () [0x00000]
at Upkg.ReleaseSpecification.ProcessDeps (System.Xml.XmlElement depsElement) [0x00000]
at Upkg.ReleaseSpecification.Process () [0x00000]
at Upkg.Branches.get_Item (System.Object key) [0x00000]
at Upkg.Branches.get_Current () [0x00000]
at Upkg.ReleaseSpecification.ProcessDeps (System.Xml.XmlElement depsElement) [0x00000]
at Upkg.ReleaseSpecification.Process () [0x00000]
at Upkg.Branches.get_Item (System.Object key) [0x00000]
at Upkg.Branches.get_Current () [0x00000]
at Upkg.ReleaseSpecification.ProcessDeps (System.Xml.XmlElement depsElement) [0x00000]
at Upkg.ReleaseSpecification.Process () [0x00000]
at Upkg.Branches.get_Item (System.Object key) [0x00000]
at Upkg.Branches.get_Current () [0x00000]
at Upkg.ReleaseList.AddRelease (System.String packageName, System.String tag, Boolean allowZombies) [0x00000]
at Upkg.ReleaseList.AddRelease (System.String packageName, System.String tag) [0x00000]
at Upkg.Application.Main (System.String[] args) [0x00000]
Could not generate script!


still get the sames thing. this happened when I tried PALDO a few months ago as well.
Profile   Private Message
Created: 2010-04-12 00:08
Highlight selected Text   Edit   Delete   Quote Reply
 Re: upkg error - cannot install or upgrade
Mitglied
 
 
 
Posts: 73
Registered: 2009-07-15
I can see that you are logged in as root.

When I log in as root, I never can get my net connection working, with Paldo. Maybe, you can, but just double check.

I never installed as root, but I cannot say that it is not possible. Anyway, just in case, try to install under your regular user account.
Profile   Private Message
Created: 2010-04-12 00:57
Highlight selected Text   Edit   Delete   Quote Reply
 Re: upkg error - cannot install or upgrade
Mitglied
 
 
 
Posts: 73
Registered: 2009-07-15
I'm using this build:

Latest x86_64 stable Live CD
Image Size: 698 MB
Build Date: 2010-04-03 13:50 GMT
Build Host: buildd3.paldo.org
http://www.paldo.org/paldo-live-cd-x86_64-stable.iso.md5


I'v installed hundreds of packages at Paldo, without a miss.

I use to clear the upkg cache in the following way:

sudo rm -rf /var/cache/upkg



[manpal@gigapal:~]$ sudo upkg-install emacs
Generating script...
Writing script...
Executing script...
The following extra packages will be installed:
emacs

Do you want to continue? [Y/n] y
Installing emacs-22.3-1 (stable)...
[manpal@gigapal:~]$


If you still cannot do it, maybe Diogo or Juerg, may come here to rescue you.

Good Luck


Profile   Private Message
Created: 2010-04-12 01:14
Highlight selected Text   Edit   Delete   Quote Reply
 Re: upkg error - cannot install or upgrade
Junior Mitglied
 
 
 
Posts: 4
Registered: 2010-04-11
I wish I could try the exact iso you are using but my machine is 32 bit
Profile   Private Message
Created: 2010-04-12 03:46
Highlight selected Text   Edit   Delete   Quote Reply
 Re: upkg error - cannot install or upgrade
Mitglied
 
 
 
Posts: 73
Registered: 2009-07-15
"I wish I could try the exact iso you are using but my machine is 32 bit"

Well, 3l3vans,

For installing purposes, it's supposed to be absolutely the same thing.

All I notice is a slight performance increase in some applications, and that is the only reason why I use a 64 bit iso. Here at Paldo, or at any distro I decided to try.

I understand that a distro that doesn't allow to install software, is a failed distro for it's user, and that is sad, as (in my opinion) so far, Paldo is the best distro in the world.

Anyway, I'm not an expert. In fact, I'm a noob.

If you still want to give it a chance, wait a couple of days for another answer, or even PM Diogo, as he is one of the Paldo's expert.
Profile   Private Message
Created: 2010-04-12 04:29
Highlight selected Text   Edit   Delete   Quote Reply
 Re: upkg error - cannot install or upgrade
Junior Mitglied
 
 
 
Posts: 4
Registered: 2010-04-11
PALDO was the first Gnu/Linux system I got to work, and got to know (about 4 years ago)
I really dig its simplicity.
Profile   Private Message
Created: 2010-04-12 04:53
Highlight selected Text   Edit   Delete   Quote Reply
 Re: upkg error - cannot install or upgrade
Mitglied
 
 
 
Posts: 73
Registered: 2009-07-15
"I really dig its simplicity." I agree.

I sticked with Paldo after I tried dozens of distros.

For one or other reason, most of them easy come and easy gone.

In the meanwhile, Paldo remained for months. Always stable, reliable, fast, and often very up to date. And although excellent, it still has plenty of room to improve.

No surprise that slowly I got accustomed to it, and my best wish is that their owners will be kind enough to keep it available to everybody.
Profile   Private Message
Created: 2010-04-12 07:48
Highlight selected Text   Edit   Delete   Quote Reply
 Re: upkg error - cannot install or upgrade
Junior Mitglied
 
 
 
Posts: 24
Registered: 2008-11-03
Some questions!

How did you delete your cache?

Did you used rm -rf /var/cache/upkg?

Did you build a package yourself?

Do you have your own local paldo repo?

 
..............................
When you need all the stunning features of MacOSX and Windows
Buy yourself a copy and live in peace!!
Profile   Private Message
Created: 2010-04-13 14:06
Highlight selected Text   Edit   Delete   Quote Reply
This topic contains further posts. Next
Page: 1 2
Subscribe Topic Subscribe Topic
powered by bitron board 1.23a