Package Search
 
Members: 351 | Topics: 766 | Posts: 3210
We welcome our newest member: Somewhat Reticent
Info
» You aren't logged in, login or registerOnline: No members and 5 guests | Time: 12:28
flash_player can not be installed
paldo Support Forum    Upkg    General Discussion
Reply Reply   Subscribe Topic Subscribe Topic
9 posts found.
 flash_player can not be installed
Senior Mitglied
 
 
 
Posts: 16777215
Registered: 2008-12-03
sudo upkg-show flash_player
Package flash_player could not be found

sudo upkg-install flash_player
Generating script...
Writing script...
Executing script...
System already up-to-date.

sudo upkg-reinstall flash_player
ERROR: Package flash_player not found.

What can I do in order to install flashplayer? (I'm using paldo stable, freshly installed)
Profile   Private Message
Created: 2009-11-20 19:36
Highlight selected Text   Edit   Delete   Quote Reply
 Re: flash_player can not be installed
Senior Mitglied
 
 
 
Posts: 216
Registered: 2008-07-04
flash_player is a closed source packages, which means paldo doesn't provide a binary package with it

You may install it with upkg-build instead

Code[In neuem Fenster öffnen]
# upkg-build flash_player

 
..............................
OSs: Paldo-testing x86_64 :: HP Pavilion dv9680ez
Profile   Private Message   E-Mail
Created: 2009-11-21 01:31
Highlight selected Text   Edit   Delete   Quote Reply
 Re: flash_player can not be installed
Administrator
 
 
 
Posts: 426
Registered: 2004-09-09
There was an issue with the flash_player spec for x86. Please try again

Code[In neuem Fenster öffnen]
upkg-install flash_player
Profile   Private Message   Web
Created: 2009-11-21 18:20
Highlight selected Text   Edit   Delete   Quote Reply
 Re: flash_player can not be installed
Senior Mitglied
 
 
 
Posts: 16777215
Registered: 2008-12-03
Hi juerg

It worked fine now. Flash works mit epiphany and firefox, thanks a lot!
Profile   Private Message
Created: 2009-11-23 22:40
Highlight selected Text   Edit   Delete   Quote Reply
 Re: flash_player can not be installed
Mitglied
 
 
 
Posts: 50
Registered: 2009-02-26
Flash_player still won't build from source for me using upkg (I'm using Opera 10.10 on paldo 1.20 testing). So I downloaded and added the Flash 10 plug-in for Opera manually. Problem is, upkg keeps trying to build flash_player during upkg-upgrade and causes upkg to abort with an error every time:

(Building flash_player-10_linux-2 (testing)...
*** ERROR: flash_player-x86-glibc-2.11-gcc-4.4-1-10_linux-2

Not sure if flash_player is working with upkg for others, but is there a way to specify a package be excluded in upkg-install or upgrade - in this instance flash_player?
Profile   Private Message
Created: 2009-12-31 07:49
Highlight selected Text   Edit   Delete   Quote Reply
 Re: flash_player can not be installed
Administrator
 
 
 
Posts: 426
Registered: 2004-09-09
Can you paste the error message you get when using the following command?

Code[In neuem Fenster öffnen]
upkg-install --verbose flash_player
Profile   Private Message   Web
Created: 2009-12-31 08:20
Highlight selected Text   Edit   Delete   Quote Reply
 Re: flash_player can not be installed
Mitglied
 
 
 
Posts: 50
Registered: 2009-02-26
Hi. Here it is:

$ sudo upkg-install --verbose flash_player
Generating script...
Processing flash_player package...
Writing script...
Executing script...
The following extra packages will be installed:
flash_player

The following packages will be built from source:
flash_player

Do you want to continue? [Y/n] y
Building flash_player-10_linux-2 (testing)...
[CHECK] download
[CHECK] [ -e /var/cache/upkg/www.paldo.org_paldo/sources/flash_player/install_flash_player_10_linux.tar.gz ] || wget -P /var/cache/upkg/www.paldo.org_paldo/sources/flash_player http://fpdownload.macromedia.com/get/flashplayer/current/install_flash_player_10_linux.tar.gz
[CHECK] mkdir -p /var/lib/upkg/{packages,files,logs,scripts}
[CHECK] unset CFLAGS CXXFLAGS CPPFLAGS DEFS LDFLAGS LD_LIBRARY_PATH LD_PRELOAD LIBS LANG LANGUAGE LC_ALL LC_CTYPE LC_NUMERIC LC_TIME LC_COLLATE LC_MONETARY LC_PAPER LC_NAME LC_ADDRESS LC_TELEPHONE LC_MEASUREMENT LC_IDENTIFICATION PATH
[CHECK] export LDFLAGS="-Wl,-O1 -Wl,--hash-style=both"
[CHECK] export LINGUAS="en en_US en_GB de de_CH de_DE fr fr_CH fr_FR it it_CH it_IT es pt pl tr"
[CHECK] export DISTRIB_RELEASE="1.20"
[CHECK] export PATH="/bin:/usr/bin:/sbin:/usr/sbin:/stage2/bin:/stage2/sbin"
[NOCHECK] env | sort
DISTRIB_RELEASE=1.20
EDITOR=vi
HISTCONTROL=ignoreboth:erasedups
HISTIGNORE=&:[bf]g:exit
HISTSIZE=5000
HOME=/root
HOSTNAME=goo
INPUTRC=/etc/inputrc
JAVA_HOME=/usr/lib/jdk
LDFLAGS=-Wl,-O1 -Wl,--hash-style=both
LESS=-iMR
LINGUAS=en en_US en_GB de de_CH de_DE fr fr_CH fr_FR it it_CH it_IT es pt pl tr
LOGNAME=root
LS_COLORS=rs=0:di=01;34:ln=01;36:mh=00:pi=40;33:so=01;35:do=01;35:bd=40;33;01:cd=40;33;01:or=40;31;01:su=37;41:sg=30;43:ca=30;41:tw=30;42:ow=34;42:st=37;44:ex=01;32:*.tar=01;31:*.tgz=01;31:*.arj=01;31:*.taz=01;31:*.lzh=01;31:*.lzma=01;31:*.tlz=01;31:*.txz=01;31:*.zip=01;31:*.z=01;31:*.Z=01;31:*.dz=01;31:*.gz=01;31:*.lz=01;31:*.xz=01;31:*.bz2=01;31:*.bz=01;31:*.tbz=01;31:*.tbz2=01;31:*.tz=01;31:*.deb=01;31:*.rpm=01;31:*.jar=01;31:*.rar=01;31:*.ace=01;31:*.zoo=01;31:*.cpio=01;31:*.7z=01;31:*.rz=01;31:*.jpg=01;35:*.jpeg=01;35:*.gif=01;35:*.bmp=01;35:*.pbm=01;35:*.pgm=01;35:*.ppm=01;35:*.tga=01;35:*.xbm=01;35:*.xpm=01;35:*.tif=01;35:*.tiff=01;35:*.png=01;35:*.svg=01;35:*.svgz=01;35:*.mng=01;35:*.pcx=01;35:*.mov=01;35:*.mpg=01;35:*.mpeg=01;35:*.m2v=01;35:*.mkv=01;35:*.ogm=01;35:*.mp4=01;35:*.m4v=01;35:*.mp4v=01;35:*.vob=01;35:*.qt=01;35:*.nuv=01;35:*.wmv=01;35:*.asf=01;35:*.rm=01;35:*.rmvb=01;35:*.flc=01;35:*.avi=01;35:*.fli=01;35:*.flv=01;35:*.gl=01;35:*.dl=01;35:*.xcf=01;35:*.xwd=01;35:*.yuv=01;35:*.cgm=01;35:*.emf=01;35:*.axv=01;35:*.anx=01;35:*.ogv=01;35:*.ogx=01;35:*.aac=00;36:*.au=00;36:*.flac=00;36:*.mid=00;36:*.midi=00;36:*.mka=00;36:*.mp3=00;36:*.mpc=00;36:*.ogg=00;36:*.ra=00;36:*.wav=00;36:*.axa=00;36:*.oga=00;36:*.spx=00;36:*.xspf=00;36:
MAIL=/var/mail/root
PATH=/bin:/usr/bin:/sbin:/usr/sbin:/stage2/bin:/stage2/sbin
PWD=/home/gube
SHLVL=1
TERM=xterm
UPKG_HOSTNAME=goo.local
USER=root
_=/usr/bin/env
flash_player_mode=build
[CHECK] set +h
[CHECK] umask 022
[NOCHECK] { [ -e /usr/lib/upkg-watch.so ] && export LD_PRELOAD=/usr/lib/upkg-watch.so ; } || { [ -e /stage2/lib/upkg-watch.so ] && export LD_PRELOAD=/stage2/lib/upkg-watch.so ; }
[NOCHECK] if [ "/usr/src" = "/usr/src" ] ; then
[CHECK] mkdir -p /usr/src
[CHECK] cd /usr/src
[NOCHECK] fi
[CHECK] rm -rf install_flash_player_10_linux
[CHECK] mkdir install_flash_player_10_linux
[CHECK] pushd install_flash_player_10_linux
/usr/src/install_flash_player_10_linux /usr/src
[CHECK] tar --no-same-owner --strip-components=0 -xf /var/cache/upkg/www.paldo.org_paldo/sources/flash_player/install_flash_player_10_linux.tar.gz
[CHECK] install -v -D libflashplayer.so /usr/lib/mozilla/plugins/libflashplayer.so
install: cannot stat `libflashplayer.so': No such file or directory
*** Error: install -v -D libflashplayer.so /usr/lib/mozilla/plugins/libflashplayer.so
*** ERROR: flash_player-x86-glibc-2.11-gcc-4.4-1-10_linux-2
Profile   Private Message
Created: 2009-12-31 13:38
Highlight selected Text   Edit   Delete   Quote Reply
 Re: flash_player can not be installed
Administrator
 
 
 
Posts: 426
Registered: 2004-09-09
I cannot reproduce the issue. Can you delete the package cache and try again?

Code[In neuem Fenster öffnen]
sudo rm -rf /var/cache/upkg

Profile   Private Message   Web
Created: 2010-01-01 15:47
Highlight selected Text   Edit   Delete   Quote Reply
 Re: flash_player can not be installed
Mitglied
 
 
 
Posts: 50
Registered: 2009-02-26
I thought I had already cleared the cache properly, but this time it made the difference and flash_player built from source successfully. Thanks.
Profile   Private Message
Created: 2010-01-01 20:32
Highlight selected Text   Edit   Delete   Quote Reply
Subscribe Topic Subscribe Topic
powered by bitron board 1.23a