Package Search
 
Members: 351 | Topics: 765 | Posts: 3209
We welcome our newest member: Somewhat Reticent
Info
» You aren't logged in, login or registerOnline: No members and 8 guests | Time: 21:29
GPT support patch for GRUB 0.9x
paldo Support Forum    Upkg    General Discussion
Reply Reply   Subscribe Topic Subscribe Topic
1 post found.
 GPT support patch for GRUB 0.9x
Mitglied
 
 
 
Posts: 70
Registered: 2008-08-24
Hi guys,

lately I've been playing with UEFI on my new mobo (Intel DP45SG). Unfortunately UEFI can't boot to "msdos" labelled disks so I changed the label to GPT (GUID Partition Type) which UEFI supports. Obviously I needed to reinstall my system. Everything seemed to work perfectly until the installer had to setup GRUB on the MBR which resulted in an error.

I searched over the net and I found out that GRUB "legacy" doesn't support GPT disks and they won't be supported upstream because EFI/GPT support is a "GRUB 2.0 thing".

I found this patch from gentoo. Can it be used for paldo too? Otherwise can GRUB 2.0 fit in the next release?

Thank you,
Alessandro.
 
..............................
Running GNU/Linux Paldo 1.18 (unstable). Rock my box!
Profile   Private Message   Web
Created: 2009-07-15 20:21 | Modified: 2009-07-15 20:21 by axelgenus
Highlight selected Text   Edit   Delete   Quote Reply
Subscribe Topic Subscribe Topic
powered by bitron board 1.23a