Package Search
 
Members: 351 | Topics: 765 | Posts: 3209
We welcome our newest member: Somewhat Reticent
Info
» You aren't logged in, login or registerOnline: No members and 5 guests | Time: 02:28
touchpad tapping disabled, again?
paldo Support Forum    paldo    Installation Support
Reply Reply   Subscribe Topic Subscribe Topic
7 posts found.
 touchpad tapping disabled, again?
Moderator
 
 
Linux-Dude
 
Posts: 1187
Registered: 2006-11-23
I just ran the latest paldo testing on my laptop.
Seems tapping got disabled again. I'll run some
test on some laptops with the latest live-cd to see
if it is only on my laptop ...
Profile   Private Message   E-Mail
Created: 2009-01-08 11:38
Highlight selected Text   Edit   Delete   Quote Reply
 Re: touchpad tapping disabled, again?
Moderator
 
 
Linux-Dude
 
Posts: 1187
Registered: 2006-11-23
well it seems it is the kernel for me. 2.6.28 disables the tapping on the touchpad somehow. If I use the old 2.6.27.10 kernel the tapping works.
Maybe 2.6.28.1 will fix this ...
Profile   Private Message   E-Mail
Created: 2009-01-08 21:40
Highlight selected Text   Edit   Delete   Quote Reply
 Re: touchpad tapping disabled, again?
Junior Mitglied
 
 
 
Posts: 32
Registered: 2008-10-22
Perhaps it isn't the kernel.

I installed the latest paldo testing, dell inspiron 6400 with a synaptics touchpad, linux-2.6.28-paldo2-x86 kernel, and tapping works perfectly.

It is an irony, because tapping drives me mad, my first action is _always_ to disable it. It should be the other way round, enabled for you, disabled for me

erch
Profile   Private Message   E-Mail
Created: 2009-01-18 21:09
Highlight selected Text   Edit   Delete   Quote Reply
 Re: touchpad tapping disabled, again?
Moderator
 
 
Linux-Dude
 
Posts: 1187
Registered: 2006-11-23
Erich, we will see what 2.6.28.1 will bring. The kernel got released 2day ...

Can you telling me how you disable the tapping anyway?
Profile   Private Message   E-Mail
Created: 2009-01-18 23:48 | Modified: 2009-01-18 23:49 by Amnon82
Highlight selected Text   Edit   Delete   Quote Reply
 Re: touchpad tapping disabled, again?
Junior Mitglied
 
 
 
Posts: 32
Registered: 2008-10-22
This works for me with a synaptics touchpad.

Here is a german instruction in the archlinux wiki:

http://wiki.archlinux.de/title/Synaptics_Touchpad_Treiber

To google for it, ask for "synaptics MaxTapTime", "synaptics MaxTapMove" or simply "disable tapping".

In short, I do this.

First, the touchpad must be recognized by X11 and you need the appropriate driver. OK. that's shipped with paldo. Here is the troubleshooting text for the driver:

http://web.telia.com/~u89404340/touchpad/trouble-shooting.txt


Then you have to insert an InputDevice-section for the touchpad into xorg.conf
_and_ you must insert a pointer to this section into the ServerLayout. - The touchpad-section contains some options, among them:

option "MaxTapTime" "0"
option "MaxTapMove" "0"

With me, it is "0" here, but you can control how hard you have to hit the touchpad to get an effect, so that entry might be interesting for you as well.

I print my adapted xorg.conf below. There I commented SHMconfig out, because I don't need (i.e. want) gsynaptics, a gnome menu entry to control the touchpad.

Best, erch

~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~/etc/X11/xorg.conf

Section "ServerFlags"
Option "DefaultServerLayout" "Default"
Option "AllowEmptyInput"
EndSection

Section "ServerLayout"
Identifier "Default"
Screen "Screen0"
InputDevice "Synaptics Touchpad"
EndSection

Section "Module"
Load "extmod"
Load "glx"
Load "dri"
Load "dbe"
Load "record"
Load "bitmap"
Load "freetype"
Load "type1"
EndSection

Section "Device"
Identifier "Card0"
Driver "intel"
Screen 0
EndSection

Section "InputDevice"
Identifier "Synaptics Touchpad"
Driver "synaptics"
Option "SendCoreEvents" "true"
Option "Device" "/dev/psaux"
Option "Protocol" "auto-dev"
Option "HorizEdgeScroll" "0"
Option "MaxTapTime" "0"
Option "MaxTapMove" "0"

# This is for gsynaptics to control the touchpad.
# Option "SHMConfig" "true"
EndSection


Section "Screen"
Identifier "Screen0"
Device "Card0"
EndSection

~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~end

Profile   Private Message   E-Mail
Created: 2009-01-19 08:53
Highlight selected Text   Edit   Delete   Quote Reply
 Re: touchpad tapping disabled, again?
Moderator
 
 
Linux-Dude
 
Posts: 1187
Registered: 2006-11-23
I look into it and add gsynaptics ...

... added it to testing. Tell me if something is wrong with it ...
Profile   Private Message   E-Mail
Created: 2009-01-20 14:25 | Modified: 2009-01-20 22:37 by Amnon82
Highlight selected Text   Edit   Delete   Quote Reply
 Re: touchpad tapping disabled, again?
Moderator
 
 
Linux-Dude
 
Posts: 1187
Registered: 2006-11-23
Profile   Private Message   E-Mail
Created: 2009-02-18 10:53
Highlight selected Text   Edit   Delete   Quote Reply
Subscribe Topic Subscribe Topic
powered by bitron board 1.23a