Package Search
 
Members: 351 | Topics: 765 | Posts: 3209
We welcome our newest member: Somewhat Reticent
Info
» You aren't logged in, login or registerOnline: No members and 3 guests | Time: 10:13
Realtek Driver Repo
paldo Support Forum    paldo    Installation Support
Reply Reply   Subscribe Topic Subscribe Topic
INTEL HDA, NVIDIA HDA, ATI HDA
3 posts found.
 Realtek Driver Repo
Moderator
 
 
Linux-Dude
 
Posts: 1187
Registered: 2006-11-23
I decided to create a new repo for paldo. In this repo you can find the fixed drivers for your realtek-chipsets.



It is located there:

http://paldo.org/~amnon/realtek-repo/

Open a terminal and use this cmd-line to add my repo to your local upkg.conf:

Code[In neuem Fenster öffnen]
sudo sed -i -e 's%<repositories>%&\n<repository>http://paldo.org/~amnon/realtek-repo/</repository>%' /etc/upkg.conf


Use this cmd to build the driver:

Code[In neuem Fenster öffnen]
sudo upkg-build --verbose realtek-alsadriver


You have to rebuild the driver at every kernel-update or alsa-(lib/utils)-update.

Filelists

realtek-alsadriver-4.0.7b.filelist
realtek-alsadriver-alsa-lib-1.0.15.filelist
realtek-alsadriver-alsa-utils-1.0.15.filelist
Profile   Private Message   E-Mail
Created: 2008-02-12 16:05 | Modified: 2008-02-23 23:57 by Amnon82
Highlight selected Text   Edit   Delete   Quote Reply
 Re: Realtek Driver Repo
Moderator
 
 
Linux-Dude
 
Posts: 1187
Registered: 2006-11-23
Updated driver to Version 5.01. Still uses ALSA-1.15.
Profile   Private Message   E-Mail
Created: 2008-02-23 23:05
Highlight selected Text   Edit   Delete   Quote Reply
 Re: Realtek Driver Repo
Junior Mitglied
 
 
 
Posts: 3
Registered: 2008-12-08
Hi,
e
I'm trying to get sound to work on an acer aspire 8930G. I went through the other posts in the forum. Now I tried to build these drivers from your repo. I got the following error:

DA_POWER_SAVE_DEFAULT" redefined
In file included from <command-line>:0:
./include/linux/autoconf.h:1816:1: warning: this is the location of the previous definition
In file included from /usr/src/realtek-alsadriver-5.01/acore/hwdep.c:1:
/usr/src/realtek-alsadriver-5.01/include/adriver.h:823: error: static declaration of 'jiffies_to_msecs' follows non-static declaration
include/linux/jiffies.h:296: error: previous declaration of 'jiffies_to_msecs' was here
/usr/src/realtek-alsadriver-5.01/include/adriver.h:842: error: static declaration of 'msecs_to_jiffies' follows non-static declaration
include/linux/jiffies.h:298: error: previous declaration of 'msecs_to_jiffies' was here
In file included from /usr/src/realtek-alsadriver-5.01/include/adriver.h:940,
from /usr/src/realtek-alsadriver-5.01/acore/hwdep.c:1:
include/linux/pci.h:668: error: expected identifier or '(' before numeric constant
In file included from /lib/modules/2.6.29.2-paldo1-x86/source/arch/x86/include/asm/pci.h:4,
from include/linux/pci.h:1057,
from /usr/src/realtek-alsadriver-5.01/include/adriver.h:940,
from /usr/src/realtek-alsadriver-5.01/acore/hwdep.c:1:
include/linux/mm.h:278: error: conflicting types for 'snd_compat_vmalloc_to_page'
/usr/src/realtek-alsadriver-5.01/include/adriver.h:744: error: previous declaration of 'snd_compat_vmalloc_to_page' was here
In file included from /usr/src/realtek-alsadriver-5.01/acore/hwdep.c:1:
/usr/src/realtek-alsadriver-5.01/include/adriver.h: In function 'snd_pci_orig_save_state':
/usr/src/realtek-alsadriver-5.01/include/adriver.h:1182: error: too many arguments to function 'pci_save_state'
/usr/src/realtek-alsadriver-5.01/include/adriver.h: In function 'snd_pci_orig_restore_state':
/usr/src/realtek-alsadriver-5.01/include/adriver.h:1186: error: too many arguments to function 'pci_restore_state'
make[3]: *** [/usr/src/realtek-alsadriver-5.01/acore/hwdep.o] Error 1
make[2]: *** [/usr/src/realtek-alsadriver-5.01/acore] Error 2
make[1]: *** [_module_/usr/src/realtek-alsadriver-5.01] Error 2
make[1]: Leaving directory `/lib/modules/2.6.29.2-paldo1-x86/source'
make: *** [compile] Error 2
*** Error: make
*** ERROR: realtek-alsadriver-2.6.29.2-paldo1-x86-x86-glibc-2.8-gcc-4.3-1-5.01-1

I'm running a clean install of 32 bit 1.18
Card is:
00:1b.0 Audio device: Intel Corporation 82801I (ICH9 Family) HD Audio Controller (rev 03)

**** List of PLAYBACK Hardware Devices ****
card 0: Intel [HDA Intel], device 0: ALC889 Analog [ALC889 Analog]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 0: Intel [HDA Intel], device 3: NVIDIA HDMI [NVIDIA HDMI]
Subdevices: 1/1
Subdevice #0: subdevice #0

Thanks for any help I can get,

loic
Profile   Private Message   E-Mail
Created: 2009-05-07 20:35
Highlight selected Text   Edit   Delete   Quote Reply
Subscribe Topic Subscribe Topic
powered by bitron board 1.23a