Package Search
 
Members: 351 | Topics: 766 | Posts: 3210
We welcome our newest member: Somewhat Reticent
Info
» You aren't logged in, login or registerOnline: No members and 6 guests | Time: 15:52
Paldo won't automout usbdisk no more - why?
paldo Support Forum    paldo    Hardware Compatibility
Reply Reply   Subscribe Topic Subscribe Topic
6 posts found.
 Paldo won't automout usbdisk no more - why?
Moderator
 
 
Linux-Dude
 
Posts: 1187
Registered: 2006-11-23
This is creasy. Why Paldo don't mount my usbdisks anymore?
What did I miss?

Can you give me some point I can start to look for?

Code[In neuem Fenster öffnen]
[amnon@amnonspc:~]$ sudo mount /dev/sdc1 /media/usbdisk
mount: you must specify the filesystem type
[amnon@amnonspc:~]$ dmesg|grep -i usb
usbcore: registered new interface driver usbfs
usbcore: registered new interface driver hub
usbcore: registered new device driver usb
usbmon: debugfs is not available
ohci_hcd: 2006 August 04 USB 1.1 'Open' Host Controller (OHCI) Driver (PCI)
ohci_hcd 0000:00:02.0: new USB bus registered, assigned bus number 1
usb usb1: configuration #1 chosen from 1 choice
hub 1-0:1.0: USB hub found
usb 1-7: new full speed USB device using ohci_hcd and address 2
ehci_hcd 0000:00:02.1: new USB bus registered, assigned bus number 2
ehci_hcd 0000:00:02.1: USB 2.0 started, EHCI 1.00, driver 10 Dec 2004
usb usb2: configuration #1 chosen from 1 choice
hub 2-0:1.0: USB hub found
usb 2-7: new high speed USB device using ehci_hcd and address 2
usb 2-7: configuration #1 chosen from 1 choice
usb 1-9: new low speed USB device using ohci_hcd and address 3
usb 1-9: configuration #1 chosen from 1 choice
Initializing USB Mass Storage driver...
scsi6 : SCSI emulation for USB Mass Storage devices
usb-storage: device found at 2
usb-storage: waiting for device to settle before scanning
usbcore: registered new interface driver usb-storage
USB Mass Storage support registered.
usbhid: Unknown symbol input_ff_create_memless
usb-storage: device scan complete
usbcore: registered new interface driver hiddev
input: B16_b_02 USB-PS/2 Optical Mouse as /class/input/input3
input: USB HID v1.10 Mouse [B16_b_02 USB-PS/2 Optical Mouse] on usb-0000:00:02.0-9
usbcore: registered new interface driver usbhid
drivers/usb/input/hid-core.c: v2.6:USB HID core driver
usb 2-7: USB disconnect, address 2
usb 2-7: new high speed USB device using ehci_hcd and address 4
usb 2-7: configuration #1 chosen from 1 choice
scsi7 : SCSI emulation for USB Mass Storage devices
usb-storage: device found at 4
usb-storage: waiting for device to settle before scanning
usb-storage: device scan complete
Profile   Private Message   E-Mail
Created: 2007-04-25 07:19 | Modified: 2007-04-25 07:23 by Amnon82
Highlight selected Text   Edit   Delete   Quote Reply
 Re: Paldo won't automout usbdisk no more - why?
Moderator
 
 
Linux-Dude
 
Posts: 1187
Registered: 2006-11-23
Code[In neuem Fenster öffnen]
usb-storage: device found at 7
usb-storage: waiting for device to settle before scanning
usb-storage: device scan complete
[amnon@amnonspc:~]$ sudo mount /dev/sdc1 /media/usbdisk
[amnon@amnonspc:~]$ ls /media/usbdisk
memstick.ind mp_root mstk_pro.ind music picture psp reboot310.def video


... manual it works, but not auto.
Profile   Private Message   E-Mail
Created: 2007-04-25 07:29
Highlight selected Text   Edit   Delete   Quote Reply
 Re: Paldo won't automout usbdisk no more - why?
Moderator
 
 
Linux-Dude
 
Posts: 1187
Registered: 2006-11-23
Code[In neuem Fenster öffnen]
[amnon@amnonspc:~]$ ls /var/lib/*.saved
ls: cannot access /var/lib/*.saved: No such file or directory
[amnon@amnonspc:~]$ ls /usr/lib/*.saved
/usr/lib/libhal.so.1.0.0.saved /usr/lib/libhal-storage.so.1.0.0.saved
[amnon@amnonspc:~]$ sudo rm libhal*.saved
rm: cannot remove `libhal*.saved': No such file or directory
[amnon@amnonspc:~]$ sudo rm /usr/lib/*.saved
[amnon@amnonspc:~]$ ls /usr/lib/*.saved
ls: cannot access /usr/lib/*.saved: No such file or directory
[amnon@amnonspc:~]$ upkg-reinstall hal
[amnon@amnonspc:~]$ ls /usr/lib/*.saved
ls: cannot access /usr/lib/*.saved: No such file or directory


seems hal was broken again. I'll check my livecd squashfs ...

... livecd-image is fine. Seems I broke it somewhere on my system during a upkg-build session, again ...
Profile   Private Message   E-Mail
Created: 2007-04-25 07:51 | Modified: 2007-04-25 07:58 by Amnon82
Highlight selected Text   Edit   Delete   Quote Reply
 Re: Paldo won't automout usbdisk no more - why?
Administrator
 
 
 
Posts: 426
Registered: 2004-09-09
I've fixed the check in upkg-remove in 0.238 to be compatible with bash 3.2, so that shouldn't happen anymore.
Profile   Private Message   Web
Created: 2007-04-25 19:58
Highlight selected Text   Edit   Delete   Quote Reply
 Re: Paldo won't automout usbdisk no more - why?
Moderator
 
 
Linux-Dude
 
Posts: 1187
Registered: 2006-11-23
Still I can only mount the external harddrives manual ...

Code[In neuem Fenster öffnen]
[amnon@amnonspc:~]$ ls /usr/lib/*.saved
/usr/lib/libupkg-watch.so.0.0.0.saved


How can I fix that or what have I to test?
Profile   Private Message   E-Mail
Created: 2007-04-29 10:26
Highlight selected Text   Edit   Delete   Quote Reply
 Re: Paldo won't automout usbdisk no more - why?
Moderator
 
 
Linux-Dude
 
Posts: 1187
Registered: 2006-11-23
Needings:

working hal, gnome-vfs, gnome-volume-manager and enabled automount in gnome-volume-manager

Test:

Code[In neuem Fenster öffnen]
[amnon@amnonspc:~]$ lshal -m

Start monitoring devicelist:
-------------------------------------------------
10:54:29.253: usb_device_1058_701_DEF10CC286AE_if0_scsi_generic removed
10:54:29.254: volume_uuid_74E7_61CC removed
10:54:29.306: usb_device_1058_701_DEF10CC286AE_if0_scsi_host_scsi_device_lun0 removed
10:54:29.307: usb_device_1058_701_DEF10CC286AE_if0_scsi_host removed
10:54:29.331: storage_serial_WDC_WD12_00UE_00KVT0_DEF10CC286AE_0_0 removed
10:54:29.332: usb_device_1058_701_DEF10CC286AE_if0 removed
10:54:29.333: usb_device_1058_701_DEF10CC286AE_usbraw removed
10:54:29.335: usb_device_1058_701_DEF10CC286AE removed
10:54:42.661: usb_device_1058_701_DEF10CC286AE added
10:54:42.682: usb_device_1058_701_DEF10CC286AE_usbraw added
10:54:42.745: usb_device_1058_701_DEF10CC286AE_if0 added
10:54:47.623: usb_device_1058_701_DEF10CC286AE_if0_scsi_generic added
10:54:47.642: usb_device_1058_701_DEF10CC286AE_if0_scsi_host added
10:54:47.648: usb_device_1058_701_DEF10CC286AE_if0_scsi_host_scsi_device_lun0 added
10:54:47.790: storage_serial_WDC_WD12_00UE_00KVT0_DEF10CC286AE_0_0 added
10:54:47.935: volume_uuid_74E7_61CC added
10:54:48.070: volume_uuid_74E7_61CC property volume.mount_point = '/media/WD Passport'
10:54:48.074: volume_uuid_74E7_61CC property volume.is_mounted = true


After updating to the newest kernel and deleting some '/usr/lib/*.saved'-files it seems to work again ...
Profile   Private Message   E-Mail
Created: 2007-04-29 11:01 | Modified: 2007-04-29 11:02 by Amnon82
Highlight selected Text   Edit   Delete   Quote Reply
Subscribe Topic Subscribe Topic
powered by bitron board 1.23a